Bug #1142

rt remote free backtrace

Added by pavalos almost 6 years ago. Updated over 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Running today's -HEAD, I'm seeing this repeated on the console every
few minutes:

rt remote free rt_cpuid 1, mycpuid 0
Trace beginning at frame 0xd73c9a70
rtfree_remote(c036f7fc,1,0,c3f63160,c3f60000) at rtfree_remote+0x74
rtfree_remote(ee926e80,0) at rtfree_remote+0x74
in_pcbdetach(db62ab20) at in_pcbdetach+0x82
tcp_close(db62abe0,ee33a040,ee33a02c,ad483ed1,d73c9b2c) at
tcp_close+0x374
tcp_drop(db62abe0,3d) at tcp_drop+0x7d
tcp_drop_syn_sent(db62ab20,3d) at tcp_drop_syn_sent+0x1c
tcp_ctlinput(b,d73c9bf8,ee33a02c) at tcp_ctlinput+0x14f
icmp_input(ee219c00,14,1) at icmp_input+0x2a6
transport_processing_oncpu(ed541818,14,0,0,0) at
transport_processing_oncpu+0x3f
ip_input(ee219c00) at ip_input+0xe0d
ip_input_handler(ee219c18) at ip_input_handler+0xe
netisr_run(2,ee219c00) at netisr_run+0x7b
ether_demux_oncpu(da55b9c0,ee219c00) at ether_demux_oncpu+0x26b
ether_input_oncpu(da55b9c0,ee219c00) at ether_input_oncpu+0xab
ether_input_handler(ee219c18) at ether_input_handler+0x3b
netmsg_service(ee219c18,1,0,c03ba5c4,ff800000) at netmsg_service+0x32
netmsg_service_loop(c03f67a8,0,0,0,0) at netmsg_service_loop+0x18
lwkt_exit() at lwkt_exit

Let me know if you need any more info.

--Peter

History

#1 Updated by pavalos almost 6 years ago

Also, this only happens when I have the new net mpsafe sysctls set to 1.

--Peter

#2 Updated by pavalos almost 6 years ago

Actually, that's not true. It just doesn't happen as often.

--Peter

#3 Updated by sepherosa over 5 years ago

Fixed by:
e387358594
14572273ec

Also available in: Atom PDF