Bug #1581

Changing the interface name through ifconfig is not reflected in pf

Added by rumcic about 5 years ago. Updated over 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

When you change a netif name through ifconfig (e.g. ifconfig emx0 name lan0),
ifconfig does show the new name when listing the interfaces, but pf rules do
not work for that interface (lan0).

After changing the name back to emx0 (through ifconfig and in pf.conf) the
rules seem to work normally.

e.g.: pass all works, but pass on lan0 all does not (but pass on emx0 all does
work when you rename the netif back to emx0)
--
Regards,
Rumko

History

#1 Updated by lentferj over 4 years ago

I have tried nat, pass and block rules on lan0 (renamed from re0) on my pf test
setup after updating to pf4.2 (commit 21fe214d4b41900174d52bd8800b5e21de6106ca).
All worked fine for me. Please test again after updating to at least that commit.

#2 Updated by rumcic over 4 years ago

Seems to be working, thx!

Also available in: Atom PDF