Bug #1928

Weird behaviour after APIC_IO changes

Added by tuxillo almost 6 years ago. Updated over 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:


Target version:-


Hi all,

After the APIC_IO changes I've noticed that some things in my computer are not
working anymore like USB ports and PS/2 mouse. Everything worked like a charm as
of last commit at October 2nd. I've build everything up (world,kernel) as of
Nov, 26th and there are differences in the verbose boot.

Find below the complete verbose dmesg and also a diff against both dmesgs
(sorted first).

Antonio Huete


#2 Updated by alexh almost 6 years ago

Obvious question: Have you tried toggling the apic_io tunable? Did you have
APIC_IO enabled before? Do you now?


#3 Updated by ahuete.devel almost 6 years ago

Hi Alex,

As you can see in both dmesgs, APIC_IO is disabled:

Warning: APIC I/O disabled

If I enable it, no hard disk is detected.

#4 Updated by tuxillo over 5 years ago

Commit 8995ba1d97e8261b45d0fdc0d710068a55f4ccc4 fixed the weirdness and the
interrupt problems for me.

Also available in: Atom PDF