Bug #2155

libmicro doesn't work after of the big vm patch

Added by juanfra684 about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

I was testing with libmicro the difference of performance of dragonfly 2.12
pre-patch vs post-patch. libmicro is a project of opensolaris for testing their
system against linux.

I ran the tests in dragonfly pre-patch and all the tests passed without
problems. I updated /usr/src, "make nativekernel", "make installkernel",
rebooted the computer and I ran the tests again.

Something kills the tests. I don't know what kill this. The tests die in
something relative to "fork".

My bug report is not for you fix the problem in libmicro. I think the kernel has
a bug relative to the vm patch and libmicro shows this.

The version of libmicro in pkgsrc is broken for all OS. I've reported the bug
(#45500). Meantime, I've made a shell script with the patches for automating the
process ( http://juanfra.info/bugs-y-listas/libmicro-dragonfly/libmicro.sh )
. Also you can download the script, to read the steps and to apply the patches
by hand.

I'm using x86 with world updated.

History

#1 Updated by juanfra684 about 3 years ago

My problems were fixed with the last patches from Matt Dillon.

Tested with master (b59b553b7009b6bf9a9a64f2d1e12f3e63509777).

Also available in: Atom PDF