Bug #2319

crypt/passwd forward compat

Added by c.turner1 over 2 years ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

New-format (since d8ee3b5d2d9ba12d8978a47bccb8e3945f96ea08)
password hashes are not compatible with programs built before
the change.

Not sure if there is a good workaround for this -
doesn't seem like there is / that it's worth the trouble
of anything like an abi bump, etc esp. post release
although perhaps adding another option for
passwd_format in login.conf to allow people to use
old format hashes might make sense if this turns out
to be a bigger deal.

I can probably hack this together if desired, but
seems discussion worthy first

Side note -

After I found out about the forward compatibility issues,
I took the liberty of updating the release page about this -

In hindsight this was probably way too unilateral and should
have been discussed somewhere first, like here. I apologise.

However what is there seemed to capture the status quo so
I'd think it should stand unless someone wants to override

Also available in: Atom PDF