Bug #2454

Kernel Panic accessing ext2fs

Added by skylarhawk about 2 years ago. Updated 10 months ago.

Status:ClosedStart date:11/14/2012
Priority:NormalDue date:
Assignee:tuxillo% Done:

0%

Category:VFS subsystem
Target version:3.8.0

Description

Kernel panic whenever doing operations touching data on an ext2 file system.

14:39 < skylarhwk> I keep getting a kernel panic on release (3.2.1) when I try to do almost any operation on an ext2fs partition
14:39 < skylarhwk> I can provide more information as needed, but can someone possibly help me with it?
14:56 <@tuxillo> skylarhwk: that's normal, it's not in shape
14:56 <@tuxillo> skylarhwk: i plan to work on it soon, if I can.
14:57 < skylarhwk> alright
14:57 <@tuxillo> :(
14:57 < skylarhwk> would the message from the panic help you w/ debugging?
14:57 < skylarhwk> or anything else?
14:57 <@tuxillo> I know it panics already, and I have coredumps
14:57 <@tuxillo> skylarhwk: can you please open a bug at bugs.dragonflybsd.org so that we don't forget about it?
14:57 <@tuxillo> thanks!
14:57 < skylarhwk> sure thing

Submitting bug as asked ;)

Thanks for for working on it. ^_^

History

#1 Updated by tuxillo about 2 years ago

  • Status changed from New to In Progress

Grab

#2 Updated by tuxillo about 2 years ago

  • Status changed from In Progress to Feedback
  • Assignee set to tuxillo

Fix pushed, commit 5f4f1383e0706850f4d42e49fc37813cf7943539

#3 Updated by skylarhawk about 2 years ago

mount_ext2fs now lets me mount the filesystem ro, and everything seems to work fine.

However, I am now unable to mount the filesystem r/w, however the output I receive seems to indicate that this is the intended behavior.

copying relevant chat messages

16:39 <@tuxillo> try a r/w mount and see what it says
16:42 <@tuxillo> skylrhawk: write anything you need in privmsg
16:46 < skylrhawk> tuxillo: uploading dmsg to pastebin
16:47 < robg> how did you mount the filesystem skylrhawk?
16:48 < skylrhawk> ---> mount_ext2fs /dev/da0s7 /mnt
16:48 < skylrhawk> dmesg --> http://pastebin.com/R8W5VLDc
16:48 < skylrhawk> last line is generated from me trying to mount it
17:02 <@swildner> skylrhawk: so yeah, what it says
17:03 <@swildner> #define EXT2_FEATURE_RO_COMPAT_SUPP EXT2_FEATURE_RO_COMPAT_SPARSE_SUPER
17:03 <@swildner> i think with this, we only support r/o mounting

17:11 < skylrhawk> but the bug I submitted was that it was giving me kernel panic on mount, and previously it let me mount r/w, but now I am unable to mount r/w and for r/o, everything goes smoothly
17:11 < skylrhawk> so I think that's a fair solution
17:12 <@swildner> hmm?
17:12 < skylrhawk> well, to correct myself, it would let me mount, but not do file ops
17:12 < skylrhawk> http://gitweb.dragonflybsd.org/dragonfly.git/commitdiff/5f4f1383e0706850f4d42e49fc37813cf7943539
17:12 <@swildner> it let you mount r/w before?
17:12 < skylrhawk> didn't seem to care
17:12 < skylrhawk> but then again, I couldn't touch it
17:12 < skylrhawk> so...
17:13 <@swildner> was the fs created with the sparse superblock feature?
17:14 < skylrhawk> I don't actually know
17:14 <@swildner> (note i have no clue about ext2, so my questions about it might sound dumb)
17:14 <@swildner> ok
17:14 < skylrhawk> created in obsd using newfs.ext2 /dev/sdaj
17:14 < skylrhawk> so default as far as I know
17:15 <@swildner> does "file - </dev/da0s7" show it?
17:17 < skylrhawk> "/dev/stdin: Linux rev 1.0 ext2 filesystem data, UUID=blahblahbla (large files)"
17:20 <@swildner> hm large files.. maybe i'm reading the code wrong and large files is what it doesn't like for r/w
17:20 <@swildner> not sure
17:21 <@swildner> weird though it would survive the mount before tuxillo's change
17:21 < skylrhawk> I don't really know either
17:37 <@vsrinivas> our ext2 works okay if no fancy features are used.
17:37 <@vsrinivas> (no dir_index, sparse super, etc...)
17:38 <@swildner> he has "large files" and it will mount r/o only
17:38 <@vsrinivas> :(
17:38 <@vsrinivas> ok, largefiles should've worked.
17:38 <@swildner> really
17:38 <@vsrinivas> think so....
17:38 < skylrhawk> ┐( ̄ー ̄)┌
17:39 <@vsrinivas> but no other new feature bits must have been on.
17:40 <@vsrinivas> dumpe2fs /dev/whatever | grep 'Filesystem features'
17:43 < skylrhawk> I only get one line: "Filesystem features: large_file"
17:43 <@swildner> ok
17:45 <@vsrinivas> hmm. weird, i think that should work, gonna try something w/ it. (thanks!)

#4 Updated by tuxillo 10 months ago

  • Description updated (diff)
  • Category set to VFS subsystem
  • Status changed from Feedback to Closed
  • Target version set to 3.8.0

Hi,

Panic reported was fixed. To know more on how to use ext2fs on DragonFly BSD, check this:

http://lists.dragonflybsd.org/pipermail/users/2014-February/090536.html

Closing this one.

Cheers,
Antonio Huete

Also available in: Atom PDF