Bug #2554

panic: chn_wrfeed(pcm0:play:2:dsp0.2): amt 4096 > source size 0, flags 0x0

Added by fgudin over 1 year ago. Updated about 1 year ago.

Status:ResolvedStart date:05/03/2013
Priority:LowDue date:
Assignee:-% Done:

100%

Category:-
Target version:-

Description

Hello,
I've been suffering from this for quite some time (couldn't pinpoint the exact moment it appeared): while playing an .avi with mplayer, the machine would dump and reboot (dump and all will be uploading to leaf in a moment). This is a small box (VIA CPU) where everything is done in software (no DRM, etc.): I suspect that for some reason mplayer doesn't keep up filling data to the sound driver buffer, and at the wrong time, the kernel attempts to feed the hw channel, and boom.
The attached patch seems to cure (I forgot it during my update to the 3.4 branch, and this morning it stroke back again). However, I'm neither certain my analysis is correct, nor that's the proper fix. Could anybody glance at it and provide advice, please ?

Thank you,
--
Francis

History

#1 Updated by fgudin over 1 year ago

Upload done: ~crash/*28*

#2 Updated by fgudin over 1 year ago

Hello,
I'd be glad if some knowledgeable people could at least give their opinion regarding the cause and pseudo-fix for this crash. If this patch can't hurt anywhere else, that'd be nice it be committed: I can keep it private, but I know for sure I'll forget it once more and will have to dig it back :)
Thank you in advance,
--
Francis

#3 Updated by ftigeot about 1 year ago

  • Description updated (diff)
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Your patch seems fine and has been pushed today.

Thanks for the fix!

Also available in: Atom PDF