Project

General

Profile

Bug #2785

pkg(8) fails to process some packages, reports a "truncated input" error

Added by ftigeot over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
02/07/2015
Due date:
% Done:

0%

Estimated time:

Description

pkg upgrade tentative on -master, with pkg-1.4.10:

[1/35] Upgrading pciids from 20150105 to 20150124...
[1/35] Extracting pciids-20150124: 0%
pkg: archive_read_extract(): truncated input
[1/35] Extracting pciids-20150124: 100%
[1/35] Deleting files for pciids-20150124: 100%
pkg: unlinkat(usr/local/share/pciids/): Bad file descriptor

History

#1

Updated by ftigeot over 4 years ago

Various people have reported similar issues on the IRC channel.

It is unclear when pkg(8) started to fail exactly since this problem does not occur systematically.

However, we can be sure pkg-1.3.x was safe.
According to the logs of my wolfpond.org mirror, pkg(8) was upgraded to version 1.4.0 on December 16, 2014.

#2

Updated by ftigeot over 4 years ago

pkg-1.3.8_3 is able to successfully upgrade a system where pkg-1.4.10 fails.

#3

Updated by ftigeot over 4 years ago

pkg-1.4.10 still fails on world+kernel from December 15, 2014 (as of commit 08223d8ccc101b6ac6cfaf19be98117596423a8b).

#4

Updated by ftigeot over 4 years ago

pkg-1.4.2 is able to successfully upgrade a system where pkg-1.4.10 fails.

#5

Updated by ftigeot over 4 years ago

pkg-1.4.4 is able to successfully upgrade a system where pkg-1.4.10 fails.

#6

Updated by ftigeot over 4 years ago

pkg-1.4.7 also fails.

#7

Updated by ftigeot over 4 years ago

pkg-1.4.6 also fails to upgrade the test system.

#8

Updated by ftigeot over 4 years ago

pkg 1.4.5 also fails.

Last good pkg version: 1.4.4
First bad pkg version: 1.4.5

#9

Updated by ftigeot over 4 years ago

pkg 1.4.5 started using chflags features.

According to tests made by zrj, chflags support is what is breaking package extraction.
pkg-1.4.10 without chflags support works as expected.

#10

Updated by dragonflybsd1 over 4 years ago

  • Status changed from New to Resolved

fixed starting with package 1.4.12

Also available in: Atom PDF