Project

General

Profile

Bug #2973

Kernel panic "faddr mismatch for reconnect"

Added by mneumann 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Networking
Target version:
-
Start date:
12/28/2016
Due date:
% Done:

0%


Description

It can be easily reproduced (at least on my box) with the following commands:

gem install --user-install taskwarrior-web
.gem/ruby/2.2/bin/task-web

Needs following packages:

ruby-2.2.6_1,1
ruby22-gems-2.6.8

Panics with "faddr mismatch for reconnect" in sys/netinet/tcp_usrreq.c.

Kernel is most recent:

4.7-DEVELOPMENT DragonFly v4.7.0.1061.g5abb6-DEVELOPMENT

I can provide crash dumps if neccessary.

History

#1 Updated by sepherosa 9 months ago

Do you have the coredump on leaf?

On Wed, Dec 28, 2016 at 7:08 PM,
<> wrote:
> Issue #2973 has been reported by mneumann.
>
> ----------------------------------------
> Bug #2973: Kernel panic "faddr mismatch for reconnect"
> http://bugs.dragonflybsd.org/issues/2973
>
> * Author: mneumann
> * Status: New
> * Priority: Normal
> * Assignee: sepherosa
> * Category: Networking
> * Target version:
> ----------------------------------------
> It can be easily reproduced (at least on my box) with the following commands:
>
> gem install --user-install taskwarrior-web
> .gem/ruby/2.2/bin/task-web
>
> Needs following packages:
>
> ruby-2.2.6_1,1
> ruby22-gems-2.6.8
>
> Panics with "faddr mismatch for reconnect" in sys/netinet/tcp_usrreq.c.
>
> Kernel is most recent:
>
> 4.7-DEVELOPMENT DragonFly v4.7.0.1061.g5abb6-DEVELOPMENT
>
> I can provide crash dumps if neccessary.
>
>
>
> --
> You have received this notification because you have either subscribed to it, or are involved in it.
> To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

--
Tomorrow Will Never Die

#2 Updated by sepherosa 9 months ago

OK, I see the issue, its connect to INADDR_ANY, huh. I will fix it shortly.

On Wed, Dec 28, 2016 at 8:44 PM,
<> wrote:
> Issue #2973 has been updated by sepherosa.
>
>
> Do you have the coredump on leaf?
>
> On Wed, Dec 28, 2016 at 7:08 PM,
> <> wrote:
>> Issue #2973 has been reported by mneumann.
>>
>> ----------------------------------------
>> Bug #2973: Kernel panic "faddr mismatch for reconnect"
>> http://bugs.dragonflybsd.org/issues/2973
>>
>> * Author: mneumann
>> * Status: New
>> * Priority: Normal
>> * Assignee: sepherosa
>> * Category: Networking
>> * Target version:
>> ----------------------------------------
>> It can be easily reproduced (at least on my box) with the following commands:
>>
>> gem install --user-install taskwarrior-web
>> .gem/ruby/2.2/bin/task-web
>>
>> Needs following packages:
>>
>> ruby-2.2.6_1,1
>> ruby22-gems-2.6.8
>>
>> Panics with "faddr mismatch for reconnect" in sys/netinet/tcp_usrreq.c.
>>
>> Kernel is most recent:
>>
>> 4.7-DEVELOPMENT DragonFly v4.7.0.1061.g5abb6-DEVELOPMENT
>>
>> I can provide crash dumps if neccessary.
>>
>>
>>
>> --
>> You have received this notification because you have either subscribed to it, or are involved in it.
>> To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account
>
>
>
> --
> Tomorrow Will Never Die
>
> ----------------------------------------
> Bug #2973: Kernel panic "faddr mismatch for reconnect"
> http://bugs.dragonflybsd.org/issues/2973#change-13043
>
> * Author: mneumann
> * Status: New
> * Priority: Normal
> * Assignee: sepherosa
> * Category: Networking
> * Target version:
> ----------------------------------------
> It can be easily reproduced (at least on my box) with the following commands:
>
> gem install --user-install taskwarrior-web
> .gem/ruby/2.2/bin/task-web
>
> Needs following packages:
>
> ruby-2.2.6_1,1
> ruby22-gems-2.6.8
>
> Panics with "faddr mismatch for reconnect" in sys/netinet/tcp_usrreq.c.
>
> Kernel is most recent:
>
> 4.7-DEVELOPMENT DragonFly v4.7.0.1061.g5abb6-DEVELOPMENT
>
> I can provide crash dumps if neccessary.
>
>
>
> --
> You have received this notification because you have either subscribed to it, or are involved in it.
> To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

--
Tomorrow Will Never Die

#3 Updated by mneumann 9 months ago

  • Status changed from New to Resolved

Fixed

Also available in: Atom PDF