Project

General

Profile

Bug #3122

syscons: keybell="visual" freezes system

Added by snurg 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Kernel
Target version:
Start date:
02/17/2018
Due date:
% Done:

0%

Estimated time:

Description

This is my first attempt to try DragonFly, so I am Dragonfly newb.
(I have more than two decades FreeBSD experience, so I am no FreeBSD newbie, though)

The steps I've done so far are described here: http://bsd.denkverbot.info/2018/02/trying-out-dragonfly-bsd-first-step.html

However I had to find that the screen inverts and then the system is frozen.

As I am deaf, the visual keybell is very important for me.
This is the reason why I gave the issue a "high" priority.

If I can do anything to test/verify, I'd be very willing to assist.

History

#1 Updated by dillon 6 months ago

  • Assignee set to dillon

I'm on it. Easily reproduced the problem on a test box, I will have it fixed in master and release (kernel sources) today. I will do a follow-up on this bug after I've committed the fixes.

-Matt

#2 Updated by dillon 6 months ago

  • Status changed from New to Closed

Ok, I believe I have pushed a good fix to both the release branch and the master branch. If you are running the initial release, enough work has built up that you should probably recompile the world and the kernel.

https://www.dragonflybsd.org/docs/handbook/Upgrading/

-Matt

#3 Updated by justin 6 months ago

snurg wrote:
> As I am deaf, the visual keybell is very important for me.
> This is the reason why I gave the issue a "high" priority.

For what it's worth, the default syscon buffer was increased 2.5x, in master:

http://lists.dragonflybsd.org/pipermail/commits/2017-December/626929.html

You are pushing it even higher, so this may be immaterial.

#4 Updated by snurg 6 months ago

dillon wrote:
> Ok, I believe I have pushed a good fix to both the release branch and the master branch. If you are running the initial release, enough work has built up that you should probably recompile the world and the kernel.
>
> https://www.dragonflybsd.org/docs/handbook/Upgrading/
>
> -Matt

Yes, I have the initial release. Will upgrade tomorrow!
Let me say big thank to both of you!
Have a nice Sunday!
Stefan

#5 Updated by dillon 6 months ago

One final reminder. If going from release to master, or from master to release, be sure to reinstall all your packages. 'pkg upgrade -f' usually suffices.

-Matt

Also available in: Atom PDF