Bug #315

pkgsrc - wip/firefox2-gtk1 - Bus error (core dumped)

Added by timofonic over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

../../../../coreconf/nsinstall/DragonFly1.6.1_OPT.OBJ/nsinstall -R -m 775
DragonFly1.6.1_OPT.OBJ/mangle
/usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/dist/bin
make[4]: Leaving directory
`/usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/security/nss/cmd/shlibsign/mangle'
cd DragonFly1.6.1_OPT.OBJ ; sh
/usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/security/nss/cmd/shlibsign/sign.sh
/usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/dist \

/usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/security/nss/cmd/shlibsign/DragonFly1.6.1_OPT.OBJ
DragonFly /usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/dist/lib \
/usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/dist/lib/libsoftokn3.so
/usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/security/nss/cmd/shlibsign/DragonFly1.6.1_OPT.OBJ/shlibsign
-v -i /usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/dist/lib/libsoftokn3.so
Bus error (core dumped)
make[3]: ***
[/usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/dist/lib/libsoftokn3.chk] Error 138
make[3]: Leaving directory
`/usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/security/nss/cmd/shlibsign'
make[2]: *** [libs] Error 2
make[2]: Leaving directory
`/usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla/security/manager'
make[1]: *** [tier_50] Error 2
make[1]: Leaving directory `/usr/obj/pkgsrc/wip/firefox2-gtk1/work/mozilla'
gmake: *** [default] Error 2
*** Error code 2

Stop.
bmake: stopped in /usr/pkgsrc/wip/firefox2-gtk1
*** Error code 1

History

#1 Updated by timofonic over 7 years ago

Forgot to say the following things:

Add "PTHREAD_AUTO_VARS=yes" to the wip/firefox2-gtk1/Makefile file.

You must add "MOZILLA_USE_XFT?="no" to mk.conf because GTK1 seems not able to
use XFT. Probably there are an equivalent option for the pkgsrc Makefile, but
not know what one is.

It seems like the package author forgot that stuff in the package, maybe the
first one can be a DragonFly exclusive issue. I will mail the package author
about this bug report too.

#2 Updated by justin over 7 years ago

Now builds, and is available in Joerg's binary pkgsrc archive for DragonFly:
ftp://packages.stura.uni-rostock.de/pkgsrc-current/DragonFly/RELEASE/i386/vulnerable/firefox-gtk1-2.0nb1.tgz

Also available in: Atom PDF