Bug #52

newaliases not run after install

Added by bsd_usr over 9 years ago. Updated over 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Greetings,

I wanted to make note that newaliases doesn't seem to be run after
installation.

How did I find this bug? Well, I installed DragonFlyBSD 1.4 (overwriting
DragonFlyBSD Preview) yesterday because I wanted to do a nice clean
installation. I came to work this morning and found this in my logs:

Jan 10 03:02:25 www sm-mta[74783]: k0AB2PmO074783: SYSERR(root): hash
map "Alias0": missing map file /etc/mail/aliases.db: No such file or
directory
Jan 10 03:02:25 www sm-mta[74787]: k0AB2PDj074787: SYSERR(root): hash
map "Alias0": missing map file /etc/mail/aliases.db: No such file or
directory
Jan 10 03:02:25 www sm-mta[74789]: k0AB2PmO074783: SYSERR(root): hash
map "Alias0": missing map file /etc/mail/aliases.db: No such file or
directory
Jan 10 03:02:25 www sm-mta[74791]: k0AB2PDj074787: SYSERR(root): hash
map "Alias0": missing map file /etc/mail/aliases.db: No such file or
directory

It's not a huge deal. After running newalises, everything seemed fine
although it seems like that's something that should be done
automatically upon installation.

Thanks,

Joseph Garcia

History

#1 Updated by dillon over 9 years ago

:
:
:Greetings,
:
:I wanted to make note that newaliases doesn't seem to be run after
:installation.
:
:How did I find this bug? Well, I installed DragonFlyBSD 1.4 (overwriting
:DragonFlyBSD Preview) yesterday because I wanted to do a nice clean
:installation. I came to work this morning and found this in my logs:
:
:Jan 10 03:02:25 www sm-mta[74783]: k0AB2PmO074783: SYSERR(root): hash
:map "Alias0": missing map file /etc/mail/aliases.db: No such file or
:directory
:Jan 10 03:02:25 www sm-mta[74787]: k0AB2PDj074787: SYSERR(root): hash
:map "Alias0": missing map file /etc/mail/aliases.db: No such file or
:directory
:Jan 10 03:02:25 www sm-mta[74789]: k0AB2PmO074783: SYSERR(root): hash
:map "Alias0": missing map file /etc/mail/aliases.db: No such file or
:directory
:Jan 10 03:02:25 www sm-mta[74791]: k0AB2PDj074787: SYSERR(root): hash
:map "Alias0": missing map file /etc/mail/aliases.db: No such file or
:directory
:
:It's not a huge deal. After running newalises, everything seemed fine
:although it seems like that's something that should be done
:automatically upon installation.
:
:Thanks,
:
:Joseph Garcia

Yup, it should have and didn't. I'll add it to the errata.

-Matt
Matthew Dillon
<>

#2 Updated by bsd_usr over 9 years ago

Matthew Dillon wrote:

>
> Yup, it should have and didn't. I'll add it to the errata.
>
> -Matt
> Matthew Dillon
> <>

I have a feeling that this occured in 1.2 as well. It's just a feeling.
It's been a long while since I installed 1.2 and there's no reason to go
back anyway, but I think it could be an old bug or something. Just
thought I'd let you know.

Joseph Garcia

#3 Updated by dillon over 9 years ago

:
:Matthew Dillon wrote:
:
:>
:> Yup, it should have and didn't. I'll add it to the errata.
:>
:> -Matt
:> Matthew Dillon
:> <>
:
:I have a feeling that this occured in 1.2 as well. It's just a feeling.
:It's been a long while since I installed 1.2 and there's no reason to go
:back anyway, but I think it could be an old bug or something. Just
:thought I'd let you know.
:
:Joseph Garcia

Yah. its one of those bugs that I think a lot of people noticed,
but then just did 'newalias' and forgot about it.

-Matt
Matthew Dillon
<>

#4 Updated by tuxillo over 7 years ago

As I've doing some new DF fresh install on my test machine, I've installed
1.12.0 and 1.12.2 recently and I have not encountered this problem with aliases.

#5 Updated by corecode over 6 years ago

bug reappeared. we need to run newaliases when populating ${DESTDIR}/etc, I
believe.

#6 Updated by swildner over 6 years ago

Fixed by 03e2a3c5ec51df1be822987bcc021bccfbd23801

Also available in: Atom PDF