Bug #735

(boot -v w/acpi) Re: strangeness on geode/alix board (www.pcengines.ch , alix.1b)

Added by andrew_atrens over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Here's with acpi .. panics pretty early on ..

OK boot -v
/modules/acpi.ko text=0x44f78 data=0x1ca8+0xbc0 syms=[0x4+0x7020+0x4+0x82a3]
SMAP type=01 base=00000000 00000000 len=00000000 0009e800
SMAP type=02 base=00000000 0009e800 len=00000000 00001800
SMAP type=02 base=00000000 000f0000 len=00000000 00010000
SMAP type=01 base=00000000 00100000 len=00000000 0f6b0000
SMAP type=04 base=00000000 0f7b0000 len=00000000 00003000
SMAP type=03 base=00000000 0f7b3000 len=00000000 0000d000
SMAP type=02 base=00000000 ffff0000 len=00000000 00010000
Copyright (c) 2003, 2004, 2005, 2006, 2007 The DragonFly Project.
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
DragonFly 1.9.0-DEVELOPMENT #3: Mon Jul 23 23:40:33 EDT 2007
atrens@ab-thinky:/usr/src/sys/compile/GENERIC
Calibrating clock(s) ... TSC clock: 497981662 Hz, i8254 clock: 1193018 Hz
CLK_USE_I8254_CALIBRATION not specified - using default frequency
CLK_USE_TSC_CALIBRATION not specified - using old calibration method
CPU: Geode(TM) Integrated Processor by AMD PCS (498.05-MHz 586-class CPU)
Origin = "AuthenticAMD" Id = 0x5a2 Stepping = 2
Features=0x88a93d<FPU,DE,PSE,TSC,MSR,CX8,SEP,PGE,CMOV,CLFLUSH,MMX>
AMD Features=0xc0400000<AMIE,DSP,3DNow!>
Data TLB: 16 entries, fully associative
Instruction TLB: 16 entries, fully associative
L1 data cache: 64 kbytes, 32 bytes/line, 1 lines/tag, 16-way associative
L1 instruction cache: 64 kbytes, 32 bytes/line, 1 lines/tag, 16-way associative
L2 internal cache: 128 kbytes, 32 bytes/line, 1 lines/tag, 4-way associative
Write Allocate Disable
real memory = 259719168 (253632K bytes)
Physical memory chunk(s):
0x00001000 - 0x0009dfff, 643072 bytes (157 pages)
0x0177a000 - 0x0f79ffff, 235036672 bytes (57382 pages)
kbdc: DIAGNOSE status:0055
kbdc: TEST_KBD_PORT status:0000
kbdc: DIAGNOSE status:0055
kbdc: TEST_KBD_PORT status:0000
avail memory = 223670272 (218428K bytes)
bios32: Found BIOS32 Service Directory header at 0xc00fa650
bios32: Entry = 0xfaac0 (c00faac0) Rev = 0 Len = 1
pcibios: PCI BIOS entry at 0xaaf0
pnpbios: Found PnP BIOS data at 0xc00fb3d0
pnpbios: Entry = f0000:b400 Rev = 1.0
Other BIOS signatures found:
Preloaded elf kernel "/kernel" at 0xc174d000.
Preloaded mfs_root "/md_image" at 0xc174d1f4.
Preloaded elf module "/modules/acpi.ko" at 0xc174d234.
wlan: <802.11 Link Layer>
crypto: <crypto core>
K6-family MTRR support enabled (2 registers)
md search: name = /kernel type = elf kernel
md search: name = /md_image type = mfs_root
md0: Preloaded image </md_image> 16777216 bytes at 0xc06f408c
md search: name = /modules/acpi.ko type = elf module
md1: Malloc disk
Math emulator present
pci_open(1): mode 1 addr port (0x0cf8) is 0x80186800
pci_open(2): mode 2 enable port (0x0cf8) is 0xff
ACPI: RSDP @ 0x0xf5bb0/0x0014 (v 0 AMDGX3)
ACPI: RSDT @ 0x0xf7b3040/0x0028 (v 1 AMDGX3 AWRDACPI 0x42302E31 AWRD 0x00000000)
ACPI: FACP @ 0x0xf7b30c0/0x0074 (v 1 AMDGX3 AWRDACPI 0x42302E31 AWRD 0x00000000)
ACPI: DSDT @ 0x0xf7b3180/0x2B6E (v 1 AMDGX3 AWRDACPI 0x00001000 MSFT 0x03000000)
ACPI: FACS @ 0x0xf7b0000/0x0040
npx0.nexus0.root0
npx0: <math processor> [tentative] on motherboard
npx0: error reporting broken; using 387 emulator
npx0: <math processor> [attached!] on motherboard
acpi0.nexus0.root0
acpi0: <AMDGX3 AWRDACPI> [tentative] on motherboard
acpi0: Power Button (fixed)
Warning: ACPI is disabling APM's device. You can't run both
ACPI timer looks BAD min = 4, max = 7, width = 3
ACPI timer looks BAD min = 4, max = 7, width = 3
ACPI timer looks GOOD min = 4, max = 6, width = 2
ACPI timer looks GOOD min = 4, max = 6, width = 2
ACPI timer looks GOOD min = 4, max = 6, width = 2
ACPI timer looks BAD min = 4, max = 7, width = 3
ACPI timer looks GOOD min = 4, max = 6, width = 2
ACPI timer looks BAD min = 4, max = 7, width = 3
ACPI timer looks BAD min = 4, max = 7, width = 3
ACPI timer looks GOOD min = 4, max = 6, width = 2
pci_open(1): mode 1 addr port (0x0cf8) is 0x80186800
pci_open(2): mode 2 enable port (0x0cf8) is 0xff
panic: AcpiOsDerivePciId unable to initialize pci bus
Trace beginning at frame 0xc176f920
panic(c1fc3b6c,c176f968,c1fc4314,c176f954,c1730aa5) at panic+0x86
panic(c1739840,1,c176f948,c1fc3b6c,0) at panic+0x86
AcpiOsDerivePciId(c1fc3b6c,c1fc4314,c176f968,c1fe1178,f0000) at AcpiOsDerivePciId+0x25
AcpiEvPciConfigRegionSetup(c20247d4,0,0,c176f998,0) at AcpiEvPciConfigRegionSetup+0x1b8
AcpiEvAddressSpaceDispatch(c20247d4,0,5c,10,c176fa34) at AcpiEvAddressSpaceDispatch+0xd1
AcpiExAccessRegion(c2027fd4,0,c176fa34,0,c176f9f8) at AcpiExAccessRegion+0x44
AcpiExFieldDatumIo(c2027fd4,0,c176fa34,0,c20237a0) at AcpiExFieldDatumIo+0x11a
AcpiExExtractFromField(c2027fd4,c20237a0,4,2,c20237a0) at AcpiExExtractFromField+0x9e
AcpiExReadDataFromField(c964b800,c2027fd4,c176fa88,0,0) at AcpiExReadDataFromField+0x15b
AcpiExResolveNodeToValue(c964b980,c964b800,6,c1fc433c,c176fae0) at AcpiExResolveNodeToValue+0x1db
AcpiExResolveToValue(c964b980,c964b800,4960,0,1176fad8) at AcpiExResolveToValue+0x78
AcpiExResolveOperands(7b,c964b988,c964b800,c2002da4,c964b800) at AcpiExResolveOperands+0x33f
AcpiDsExecEndOp(c964b800,c964b824,c2002da4,c964b800,c1fa0ce0) at AcpiDsExecEndOp+0xe7
AcpiPsParseLoop(c964b800,0,c2023f94,0,c1fa0ce0) at AcpiPsParseLoop+0x2d1
AcpiPsParseAml(c964b800,c2023fd4,0,c1fa0ce0,1) at AcpiPsParseAml+0x79
AcpiPsExecuteMethod(c1fa0ce0,c1fa0ce0,c95cd5dc,c176fb8c,c1724c91) at AcpiPsExecuteMethod+0xbe
AcpiNsEvaluate(c1fa0ce0,0,c95cd5dc,c1fc4404,c176fbb0) at AcpiNsEvaluate+0x9a
AcpiUtEvaluateObject(c1fc4404,c1734f7e,1,c176fba4,0) at AcpiUtEvaluateObject+0x44
AcpiUtExecute_STA(c1fc4404,c95cd5dc,68,0,c960a818) at AcpiUtExecute_STA+0x1e
AcpiGetObjectInfo(c1fc4404,c176fbe4,ffffffff,0,c1fc4404) at AcpiGetObjectInfo+0x128
acpi_DeviceIsPresent(c960a818,c1fc4404,c960a818,c960a278,6) at acpi_DeviceIsPresent+0x8a
acpi_probe_child(c1fc4404,3,c960a278,0,0) at acpi_probe_child+0x13e
AcpiNsWalkNamespace(0,c1fc2a14,64,1,c1727fa1) at AcpiNsWalkNamespace+0x96
AcpiWalkNamespace(0,c1fc2a14,64,c1727fa1,c960a278) at AcpiWalkNamespace+0x4e
acpi_probe_children(c960a278,c173aa00,c95bf000,c960a278,c960a278) at acpi_probe_children+0x4f
acpi_attach(c960a278) at acpi_attach+0x5a1
device_doattach(c960a278,c960a1e8,c960a1a0,c960a278,c960a1a0) at device_doattach+0x53
device_probe_and_attach(c960a278) at device_probe_and_attach+0x161
bus_generic_attach(c960a1a0,c960a1a0,c960a1a0,1,c176fd4c) at bus_generic_attach+0x14
nexus_attach(c960a1a0) at nexus_attach+0xf
device_doattach(c960a1a0,c05cc1e8,c960a038,c960a1a0,c9633e24) at device_doattach+0x53
device_probe_and_attach(c960a1a0) at device_probe_and_attach+0x161
root_bus_configure(c176fd98,c029da74,0,176cc00,177a000) at root_bus_configure+0x24
configure(0,176cc00,177a000,0,c0140afb) at configure+0x8
mi_startup(176c000,0,0,0,0) at mi_startup+0x93
begin() at begin+0x42
Debugger("panic")
Stopped at Debugger+0x37: movb $0,in_Debugger.0
db>

History

#1 Updated by dillon over 7 years ago

:Here's with acpi .. panics pretty early on ..

The BIOSes own Acpi code is panicing because it can't find the
PCI bus. I don't think there's anything we can do unless one of
the other operating systems boots on the box and is able to find the
PCI bus.

-Matt

Also available in: Atom PDF