Bug #914

Reading DVD video broken in recent current

Added by steve over 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Hi,

I switched to current (7 Jan) from preview to try the new dri. Now
when I try to watch a DVD video (or read it in any way) the process reading
the DVD locks and I get errors like this in the log:

---------------
Jan 10 20:17:50 df1 kernel: ata0: FAILURE - non aligned DMA transfer
attempted Jan 10 20:17:50 df1 kernel: acd0: setting up DMA failed
---------------

Possibly related - atacontrol doesn't seem to work

atacontrol list - just hangs

atacontrol mode 0 - gives

atacontrol: ioctl(ATAGMODE): Inappropriate ioctl for device

I was about to add that burning and mounting data discs works fine
when I noticed that these use /dev/cd0 not /dev/acd0, which led me to
discover that watching DVDs from /dev/cd0 works fine.

I am using nata, which has worked fine before now.

Hardware is an ASUS A8V motherboard - DVD drives are both LiteOn
(LH-20A1P and SOHD-167T) UDMA33. The SATA hard disc works fine.

History

#1 Updated by TGEN over 6 years ago

Use natacontrol(8).

Cheers,
--
Thomas E. Spanjaard

#2 Updated by steve over 6 years ago

On Fri, 11 Jan 2008 16:11:25 +0000
"Thomas E. Spanjaard" <> wrote:

Thanks that works - spot the guy who hasn't tried atacontrol since
switching to nata some moons ago.

#3 Updated by steve over 6 years ago

Hi,

Now using an up to date preview I get various DMA errors when
trying to watch or otherwise read an encrypted DVD using either acd or cd
devices. Errors include:

Feb 27 12:33:54 df1 kernel: ata1: FAILURE - non aligned DMA transfer
attempted Feb 27 12:33:54 df1 kernel: acd1: setting up DMA failed

and

Feb 27 11:56:24 df1 kernel: acd1: setting up DMA failed
Feb 27 11:56:24 df1 kernel: ata1: FAILURE - oversized DMA transfer attempt
131072 > 65536

Strangely mounting the DVD (either via cd or acd devices) works
fine and I can read the encrypted vobs with no trouble (sum works fine for
example). I can also play DVDs by using natacontrol to turn off DMA but it
eats CPU horribly.

It seems that something in libdvdcss is triggering the problem
which is odd as that is purely userland code - the only clue I can see is
that it seems to use readv a lot so perhaps there is some path by which
readv is doing bad things with DMA ?

I'll investigate more as time permits - if I can find the code for
readv that is.

#4 Updated by steve about 6 years ago

Hi,

I found that compiling libdvdcss with CCVER=gcc34 makes encrypted
DVD reading work.

#5 Updated by hasso almost 6 years ago

Should be fixed.

Also available in: Atom PDF