Bug #2414

Updated by tuxillo 3 months ago

The Lenovo S10 is a netbook that apparently uses an Intel 945 express chipset.

I can't say any recent update has broken booting when acpi is enabled: acpi has never functioned for DragonFly.



Using master through 859bc3f7658630c523bbad944a2b95089f48de46 tcp: RFC3517bis is now officially RFC6675



Locks up after booting with acpi enabled at:



cryptosoft0: <software crypto> [attached!] on motherboard

acpi0.nexus0.root0

acpi0: <LENOVO CB-01> [tentative on motherboard]

ndepotmags=6 x mag_cap=22 for Acpi-Namespace

ndepotmags=6 x mag_cap=22 for Acpi-State

ndepotmags=6 x mag_cap=22 for Acpi-Parse

ndepotmags=6 x mag_cap=22 for Acpi-ParseExt

ndepotmags=6 x mag_cap=22 for Acpi-Operand

IOAPIC: irq9, gsi 9 edge/high -> level/low



Here are some pieces from dmesg after booting with acpi disabled:



ACPI SDT: RSDP not in EBDA

ACPI SDT: RSDP in BIOS mem

ACPI FADT: SCI irq 9, level/low

MPTABLE: warning duplicated PCI int entry for bus 0, dev 29, pin 0

MPTABLE: warning duplicated PCI int entry for bus 0, dev 31, pin 1

MPTABLE: warning duplicated PCI int entry for bus 0, dev 31, pin 1

...

CPU: Intel(R) Atom(TM) CPU N270 @ 1.60GHz (1596.02-MHz 686-class CPU)

Origin = "GenuineIntel" Id = 0x106c2 Stepping = 2

Features=0xbfe9fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>

Features2=0x40c39d<SSE3,DTES64,MON,DS_CPL,EST,TM2,SSSE3,xTPR,PDCM,MOVBE>

AMD Features=0x100000<NX>

AMD Features2=0x1<LAHF>

...

ACPI MADT: LAPIC address 0xfee00000, flags 0x1

ACPI MADT: BSP apic id 0

ACPI MADT: cpu id 0, apic id 0

ACPI MADT: cpu id 1, apic id 1

lapic: divisor index 0, frequency 66500312 Hz

SMP: CPU0 apic_initialize():

lint0: 0x00010700 lint1: 0x00000400 TPR: 0x00000000 SVR: 0x000001ff

SMP: Waiting APs LAPIC initialization

SMP: CPU1 apic_initialize():

lint0: 0x00010000 lint1: 0x00010400 TPR: 0x00000000 SVR: 0x000001ff

ACPI MADT: warning invalid intsrc irq 9 trig, level

ACPI MADT: IOAPIC addr 0xfec00000, apic id 2, gsi base 0

ACPI MADT: INTSRC irq 0 -> gsi 2 edge/high

...

IOAPIC: irq 9, gsi 9 -> cpu0 (sci)

IOAPIC: irq 9 -> gsi 9 edge/high

...

IOAPIC: legacy irq max 24

...

ELCR Found. ISA IRQs programmed as:

0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15

E E E L E L E E E E L L E E E E

MPTABLE: 0:28 INTA -> IOAPIC 0.17

MPTABLE: 0:27 INTA -> IOAPIC 0.22

MPTABLE: 0:29 INTB -> IOAPIC 0.19

MPTABLE: 0:2 INTA -> IOAPIC 0.16

MPTABLE: 0:28 INTB -> IOAPIC 0.16

MPTABLE: 0:28 INTC -> IOAPIC 0.18

MPTABLE: 0:29 INTA -> IOAPIC 0.23

MPTABLE: 0:29 INTC -> IOAPIC 0.18

MPTABLE: 0:29 INTD -> IOAPIC 0.16

MPTABLE: 0:31 INTB -> IOAPIC 0.19

MPTABLE: 2:0 INTA -> IOAPIC 0.16

...

BITS within APICID: logical_CPU_bits: 1; core_bits: 0

CPU Topology: cores_per_chip: 1; threads_per_core: 2; chips_per_package: 1;

Start scheduler helpers on cpus:

cpu0 - HyperThreading available. Core siblings: cpu0 cpu1

cpu1 - HyperThreading available. Core siblings: cpu0 cpu1

start dummy scheduler helpers on cpus: 0 1

...

IOAPIC: rman cpu0 0 - 1

IOAPIC: rman cpu0 3 - 95

IOAPIC: rman cpu0 97 - 191

IOAPIC: rman cpu1 24 - 95

IOAPIC: rman cpu1 97 - 191

npx0.nexus0.root0

npx0: <math processor> [tentative] on motherboard

npx0: INT 16 interface

Using XMM optimized bcopy/copyin/copyout

npx0: <math processor> [attached!] on motherboard

cryptosoft0.nexus0.root0

cryptosoft0: <software crypto> [tentative] on motherboard

crypto: assign cryptosoft0 driver id 0, flags 234881024

crypto: cryptosoft0 registers alg 1 flags 0 maxoplen 0

...

crypto: cryptosoft0 registers alg 17 flags 0 maxoplen 0

cryptosoft0: <software crypto> [attached!] on motherboard

pci_open(1): mode 1 addr port (0x0cf8) is 0x8000fa04

pci_open(1a): mode1res=0x80000000 (0x80000000)

pci_cfgcheck: device 0 [class=060000] [hdr=00] is there (id=27ac8086)

pcibios: BIOS version 3.00

$PIR: checksum failed!

pcib0.legacy0.nexus0.root0

pcib0: <MPTABLE Host-PCI bridge> [tentative] pcibus 0 on motherboard

pci0.pcib0.legacy0.nexus0.root0

pci0: <PCI bus> [tentative] on pcib0

pci0: domain=0, physical bus=0

found-> vendor=0x8086, dev=0x27ac, revid=0x03

domain=0, bus=0, slot=0, func=0

class=06-00-00, hdrtype=0x00, mfdev=0

cmdreg=0x0106, statreg=0x2090, cachelnsz=0 (dwords)

lattimer=0x00 (0 ns), mingnt=0x00 (0 ns), maxlat=0x00 (0 ns)

found-> vendor=0x8086, dev=0x27ae, revid=0x03

domain=0, bus=0, slot=2, func=0

...

agp0: <Intel 945GME SVGA controller> [attached!] on vgapci0

...

usb0: <Intel 82801G (ICH7) USB controller> [tentative] on uhci0

Back