Project

General

Profile

Actions

Bug #1047

closed

buildworld fails on just updated source

Added by nonsolosoft over 13 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

  1. make buildworld
    [...]
    ===> usr.bin/kdump
    sh /usr/src/usr.bin/kdump/mkioctls
    /usr/obj/usr/src/world_i386/usr/include > ioctl.c
    /usr/src/usr.bin/kdump/mkioctls: awk: Argument list too long
    /usr/src/usr.bin/kdump/mkioctls: awk: Argument list too long

more info on:

http://rafb.net/p/1H5KtE42.html

Actions #1

Updated by corecode over 13 years ago

This is a valid error, but you should be able to work around it by
running make cleandir in all module directories where you manually built
modules. At least this used to be the cause.

cheers
simon

Actions #2

Updated by matthias over 13 years ago

Close issue. A make cleandir as corecode@ suggested will fix it.

Actions

Also available in: Atom PDF