Project

General

Profile

Actions

Bug #1259

closed

installer does not set nohistory flag for hammer pfs

Added by corecode almost 13 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Unlike hammer.sh, the installer does not set the nohistory flag for those pfs
which should be created without history.

Actions #1

Updated by swildner almost 13 years ago

grab

Actions #2

Updated by swildner almost 13 years ago

For which PFS did you observe this? The only difference to hammer.sh I could
find was /tmp which isn't chflags nohistory'd in the installer (I'll fix that).

Actions #3

Updated by corecode almost 13 years ago

In my install, no pfs had the nohistory flag set

Actions #4

Updated by corecode over 12 years ago

Just to follow up - this still exists in the release installer. Something
definitely is wrong.

Actions #5

Updated by swildner over 12 years ago

Simon 'corecode' Schubert (via DragonFly issue tracker) schrieb:

Unlike hammer.sh, the installer does not set the nohistory flag for those pfs
which should be created without history.

The problem is not in the installer, but rather cpdup resetting the
chflags changes again when files are copied.

And regarding hammer.sh, I just tested it, and no flags were set after
installation either. Are you really sure it worked for you?

Sascha

Actions #6

Updated by corecode over 12 years ago

Sascha Wildner (via DragonFly issue tracker) wrote:

And regarding hammer.sh, I just tested it, and no flags were set after
installation either. Are you really sure it worked for you?

No, I'm not sure at all.

Actions #7

Updated by swildner over 12 years ago

I've committed a workaround:

6b8a26e2a91661b74c4082dcc0d43de60b121803

Actions #8

Updated by swildner over 12 years ago

...and one for hammer.sh too:

fb422ccafeeaf8e9dc595841a308211d5b2a73f1

Actions

Also available in: Atom PDF