Project

General

Profile

Actions

Bug #1388

closed

m_copydata panic in vkernel

Added by sepherosa over 12 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Kernel
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

On Mon, May 25, 2009 at 1:07 AM, Matthew Dillon
<> wrote:

While running stress2 using trevorjk's vkernel setup with the
latest head as of last night (after my second round of pthread
fixes for the vkernel) I got a mbuf panic:

Hoho, I tried to reproduce it in real kernel but failed in the last two days :P
I will try vkernel today.

panic: m_copydata, negative off -1
mp_lock = 00000001; cpuid = 1
Trace beginning at frame 0x57a9ea04
panic(57a9ea28,c,0,579218c0,57a9ea38) at 0x80bb436
panic(823d90d,ffffffff,c,0,579218c0) at 0x80bb436
m_copydata(0,ffffffff,1,59305dbc,0) at 0x80eacdc
tcp_output(579218c0,59305d18,57a9eb44,59305d9c,59305d88) at 0x815e3bc
tcp_input(59305d00,14,6,59305d00,584aae20) at 0x815d29a
ip_reass(283a0150,14,0,0,0) at 0x8153362
ip_input(59305d00,57a9ed60,8136b31,59305d18,1) at 0x8154a73
ip_input(59305d18,1,8342c68,57a9ed84,8160775) at 0x8154aa7
netmsg_service(59305d18,1,0,1,414003b8) at 0x8136b31
tcpmsg_service_loop(0,0,0,0,0) at 0x8160775
Debugger("panic")

The vkernel is bring run on my 2xCPU test box, configured -n 2 -m 128m.

-Matt
Matthew Dillon
<>

Actions #1

Updated by tuxillo almost 8 years ago

  • Description updated (diff)
  • Category set to Kernel
  • Status changed from New to In Progress
  • Assignee deleted (0)
  • Target version set to 3.8

Hi,

Was this running a particular test or running all the tests?

Cheers,
Antonio Huete

Actions #2

Updated by tuxillo almost 7 years ago

  • Status changed from In Progress to Closed

Hi,

I haven't been able to reproduce it (with the test I've tried)
Feel free to reopen it (or open a new one) if you think the issue is still there.

Cheers,
Antonio Huete

Actions

Also available in: Atom PDF