Bug #1718


IDE disk drive not detected by x86_64 2.6.1 Live CD

Added by bcox over 14 years ago. Updated over 2 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:


I've been attempting to install DragonFly 2.6.1 (x86_64 version) onto an IDE
hard drive with no luck so far. I have a Gigabyte EP45-DS3L motherboard with a
JMicron JMB368 IDE controller, a SATA DVD drive, a SATA2 WD Caviar disk drive
and an older WD Caviar IDE drive. Both SATA drives are running in AHCI mode and
are detected by the kernel just fine. (Unfortunately, I don't have enough
contiguous free space to install DragonFly with the HAMMER filesystem on the
SATA disk drive, hence the reason I tried to use the older spare IDE drive.)

FreeBSD 8.0 Live CD and Debian Linux 2.6.32 can see all three drives just fine,
but for some reason the IDE disk isn't getting attached by DragonFly. I tried
turning off AHCI mode and running the SATA drives in legacy IDE mode, and
DragonFly finds the SATA drives (as IDE devices) just fine, but still no
attachment of the IDE disk. My BIOS also has an option to run SATA drives in
"native IDE" mode, but that caused all sorts of problems involving
"TEST_UNIT_READY taskqueue timeout" and "xft: func = 0xffffffff8016b5d8 arg=0"
error messages and resulted in the kernel getting stuck in timeout loops. I
should note that the JMicron controller itself is detected in all cases.

Matt Dillon helped me out on the IRC channel and suggested some things like
booting without ACPI, but nothing worked in the end. He suspects that there's a
PCI resource issue involved.

Attached is the verbose dmesg output with AHCI mode enabled for the SATA drives.
In it I found that device_probe_and_attach is returning error code 6 when
probing the JMicron controller (atapci0).


dfbsd.dmesg (58.3 KB) dfbsd.dmesg bcox, 04/08/2010 03:54 AM
dfbsd.pciconf (1.8 KB) dfbsd.pciconf bcox, 04/08/2010 03:54 AM
Actions #1

Updated by bcox over 14 years ago

Attaching pciconf -l output.

Actions #2

Updated by tuxillo over 9 years ago

  • Description updated (diff)
  • Category set to Kernel
  • Status changed from New to Feedback
  • Assignee deleted (0)
  • Target version set to 4.2


Is it possible that you try it again with latest master?

Antonio Huete

Actions #3

Updated by tuxillo about 3 years ago

  • Target version changed from 4.2 to 6.0
Actions #4

Updated by tuxillo over 2 years ago

  • Target version changed from 6.2 to Unverifiable

Also available in: Atom PDF