Bug #2106


Official i386 images broken

Added by namor about 12 years ago. Updated almost 6 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:



i've been trying to install dragonflybsd on an old i386 machine and pkgin and the rest of the package system didn't work correct or at all.

Tracking the issue, if found plenty of config files to be just binary garbarge. Some of them are:


file (1) just says it's 'data'. cat (1) puts some blanks and the curser is at a weird place after catting any of these files. hexdump (1) shows plenty of zero-bytes and some others. Long story short: These file are broken.

What have i done to verify that my images aren't broken or it's specific to my system:

(the files were always broken)

- verified the md5 checksum of the installation image
- burned it twice on two difference dvds (and installed it twice)
- finally, installed it on another machine in a VirtualBox VM
- tried a current snapshot image, same error
(snapshot: DragonFly-i386-20110726-DEV-v2.11.0.586.ga700a.iso)

At first it thought the image itself contains invalid files, but that doesn't seem to be the case:

- on the installer dvd (live system), the file /usr/pkg/etc/mk.conf at least looks fine.
=> the files are broken AFTER installation

As for the rest of the system:

- everything's fine. I checked all files in /etc with find -name "*.conf" and the header files in /usr/pkg/include, they all show ASCII or something more meaningful when inspected with file (1).

What i have not checked:

- Different settings during installation, i always used the following:
- (as said: i386)
- no swap
- boot with default size of 768MiB
- root as encrypted hammerfs

I doubt it's a filesystem or encryption problem, though, since it's just a few files and always the same.

You can verify this yourself: Just install the official i386 image in a VirtualBox. (i had to do it with ACPI disabled)

- With the bug, it is impossible to install or delete any pkgsrc packages, with or without pkgin.

Roman Nauamnn

Actions #1

Updated by eadler almost 6 years ago

  • Description updated (diff)
  • Status changed from New to Closed
  • Assignee deleted (0)

This is limited to i386 which we no longer support. Closing.


Also available in: Atom PDF