Bug #2619

DragonFly 3.6 can't be installed on a 6TB volume

Added by ftigeot almost 7 years ago. Updated over 6 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:


I tried to install DragonFly on a batch of Xeon E5v2 workstations.
These machines have a 6TB mfid0 boot volume (RAID 5 of 4x2TB disks on a LSI 9260-4i adapter).

The installation fails almost immediately and these messages are shown in a dialog box:

fdisk: WARNING line 1: number of cylinders (726552) may be out of range
(must be within 1-1024 for normal BIOS operation, unless the entire disk is dedicated to DragonFly
fdisk: ERROR: could not adjust partition to start on a head boundary and end on a cylinder boundary.



Updated by ftigeot over 6 years ago

This may actually be a mfi-specific issue.

The installer also failed to install DragonFly on a 300GB mfi volume.

I fixed it by running fdisk -BI /dev/mfid0 from a shell.


Updated by zcrownover over 6 years ago

  • Category set to Driver

So should this be closed or retitled to reflect it affecting a specific hardware type and not the size of the disk?


Updated by swildner over 6 years ago

  • Category changed from Driver to Kernel

This issue neither specific to the disk size nor to the mfi(4) driver generally.

We have a guy in the IRC channel who runs DragonFly on a large system with (IIRC) 15x3TB with mfi(4):

Filesystem Size Used Avail Capacity Mounted on
ROOT 35T 1.6G 35T 0% /
devfs 1.0K 1.0K 0B 100% /dev
/pfs/@@-1:00001 35T 1.6G 35T 0% /var
/pfs/@@-1:00002 35T 1.6G 35T 0% /tmp
/pfs/@@-1:00003 35T 1.6G 35T 0% /usr
/pfs/@@-1:00004 35T 1.6G 35T 0% /home
/pfs/@@-1:00005 35T 1.6G 35T 0% /usr/obj
/pfs/@@-1:00006 35T 1.6G 35T 0% /var/crash
/pfs/@@-1:00007 35T 1.6G 35T 0% /var/tmp
procfs 4.0K 4.0K 0B 100% /proc

Also available in: Atom PDF