Project

General

Profile

Actions

Bug #2678

closed

kernel panic during make installworld in upgrade from 3.6.2 to 3.8.0

Added by edwardm over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/06/2014
Due date:
% Done:

0%

Estimated time:

Description

After I execute 'make installworld' i get a kernel panic.

note: The core.txt.0 was copied after the first reboot to /var/crash when i reinstalled 3.6.2


Files

core.txt.0 (103 KB) core.txt.0 edwardm, 06/06/2014 11:51 PM
Actions #1

Updated by jorisgio over 7 years ago

  • Status changed from New to Feedback

thanks for the report. Since you reinstalled the OS after the dump, some modules are missing debug symbols (like vn). Hence, i can only guess, but I've fixed a locking issue in 47dffa7f5958b75a660684b64c1d58afc637daef. I'm not 100% sure it's the cause of your panic since i've still to reproduce the panic.

Actions #2

Updated by edwardm over 7 years ago

jorisgio wrote:

thanks for the report. Since you reinstalled the OS after the dump, some modules are missing debug symbols (like vn). Hence, i can only guess, but I've fixed a locking issue in 47dffa7f5958b75a660684b64c1d58afc637daef. I'm not 100% sure it's the cause of your panic since i've still to reproduce the panic.

Thank you for your time and help, I really appreciated.

It is difficult to get a good core.txt file after the system panics. After I do a 'call dumpsys' and reboot the system the boot loader is lost and
kernel. i try booting by loading the old loader and kernel but get I no loader, kernel found. I reinstall the OS so i could try again with the save
sources i have, but i saw after the reinstall, the core file was copied into /var/crash, I used that to upload.

I reinstalled the OS untared my sources 3.8.0 did a git pull
the OS still panics and a lock is getting lost.
a message i get is: panic: lockmgr LK_RELEASE: no lock held

if needed i can start the process again and type the rest of the screen message?

Best regards,
Ed

Actions #3

Updated by jorisgio over 7 years ago

Are you saying you can reproduce the bug ? That's cool.
On the other hand, please not i've only pushed the fix to 3.9, not to 3.8.0. I should have make it more clear sorryu.

If you want to test it again, you can do a "git cherry-pick 47dffa7f5958b75a660684b64c1d58afc637daef" to get the fix in 3.8

Actions #4

Updated by edwardm over 7 years ago

I tried git cherry-pick 47dffa7f5958b75a660684b64c1d58afc637daef after i untared my 3.8.0 sources in /usr/src/ dir

i received the message 'Please tell me who you are" and ask me to run
git config --global user.email ""
git config --global user.name "your name"

i did both,then i tried git cherry-pick 47dffa7f5958b75a660684b64c1d58afc637daef again
now i get:

error: your local changes would be overwritten by cherry-pick
hint: commit your changes or stash them to proceed
fatal: cherry-pick failed.

in this case what would i do?

Actions #5

Updated by jorisgio over 7 years ago

What do you mean by "untar" ? Why are you using tar instead of git ?

Actions #6

Updated by edwardm over 7 years ago

jorisgio wrote:

What do you mean by "untar" ? Why are you using tar instead of git ?

I do a git fetch origin, git branch DragonFly_RELEASE_3_8 orgin/DragonFly_RELEASE_3_8
git checkout DragonFly_RELEASE_3_8

then I create a tar of  the src dir if i need to reinstall or install the OS in another system.
so I will not need to download the entire sources again from the server with git; i untar the src tar i created then
do git pull to pull the the newest changes, if any.
Actions #7

Updated by edwardm over 7 years ago

Okay I removed my src directory I cereated from my tar and ran make src-create,etc then ran git cherry-pick
i got the new 'kernel disk/vn' changes.

will only use git to setup my src dir.

thanks

Actions #8

Updated by edwardm over 7 years ago

edwardm wrote:

Okay I removed my src directory I cereated from my tar and ran make src-create,etc then ran git cherry-pick
i got the new 'kernel disk/vn' changes.

will only use git to setup my src dir.

thanks

make installworld panic again, however this time a different message was issue:

panic string: assertion "*kup < 0" failed in kfree at build/home/justin/src/kern/kern_slaballoc.c:1233

i tried creating a core.txt file but during reboot again the loader and kernel were wipe out so
I installed dragonfly and few files were copied into /var/crash except the core.txt.

i decided to try master;reinstalled os, since kernel and loader were wiped out(kept getting no laoder kernel found), did make src-create, switched my branch to master did the
require makes and make installworld was able to finish,
did make upgrade then rebooted.

I am running DragonFly v3.9.0.80.g66632c-DEVELOPMENT 
I guess the issue is solved for future releases?

Thanks for you great help and i enjoyed working with you
I really appreciate it.

best regards
ed

Actions #9

Updated by jorisgio over 7 years ago

  • Status changed from Feedback to Resolved

You're really unlucky ! Anyway, thank you for the effort you're putting into this.
If you have the vmcore.X and the kern.X file, you can get the backtrace doing "kgdb -n X" and then "bt" in kgdb. I'll print the backtrace. I don't see any commit about kmalloc in recent history.

If you still have the core files, please open a new issue. I'll close this one since it's apparently fixed.

thanks,
joris

Actions

Also available in: Atom PDF