Bug #2731


Screen full of random colors when starting Xorg with Intel Haswell HD Graphics P4600

Added by jkatzmaier about 9 years ago. Updated about 9 years ago.

In Progress
Target version:
Start date:
Due date:
% Done:


Estimated time:


I'm running the DragonFly 4.0 RC on an Intel Xeon(R) CPU E3-1245 v3 with HD Graphics P4600 (PCI vendor 8086, PCI Device 041a).

When starting Xorg using xinit or startx using either XFCE4 or KDE4 (my preferred DE) as session managers, the screen becomes full of colors that change randomly, almost with a rainbow effect. Absolutely no GUI elements are shown. No errors appear in the Xorg.0.log file. I've disabled acceleration in xorg.conf via NoAccel in the device section. I've also tried both the 2.21 and 2.99 versions of the Intel Xorg driver, with no change.

Please let me know what to do to help troubleshoot the issue and/or any additional information you may need.

-John Katzmaier


Xorg.0.log.xz (4.99 KB) Xorg.0.log.xz jkatzmaier, 11/10/2014 09:40 AM
dmesg.txt.xz (4.97 KB) dmesg.txt.xz jkatzmaier, 11/10/2014 09:40 AM
Actions #1

Updated by ftigeot about 9 years ago

I assume the computer to still be operating perfectly except for the weird graphics.

What sort of monitor and display connection are you using ?

Could you please attach your Xorg.0.log file as well as a copy of the dmesg output ?

Updated by jkatzmaier about 9 years ago


Thank you for responding so quickly. Yes, the computer operates perfectly in that condition, aside from being unable to use Xorg. I can ssh in to the PC (I haven't tried using Ctrl-Alt-F1 to switch consoles, as I don't think that functionality is available yet, correct?) and I can see the XFCE-related processes running and I can do anything I want to at the command line.

The monitor is a ViewSonic VG2230wm. It has a bad EDID in the DVI EEPROM, so I'm using the VGA connection, since that has a proper EDID.

Attached are the files you requested. Thank you very much for your assistance!

Actions #3

Updated by ftigeot about 9 years ago

  • Status changed from New to In Progress

Hi, no problem and thanks for the files.

Virtual consoles are not able to display anything once the gpu has been switched to a graphic mode. However, data input is still functional. It's possible to type commands blindly.

I was able to reproduce your issue on a Haswell box. I'm afraid it's something general having to do with the vga output.
In my case, I got a screen full of a random solid color, the color being different after a reboot and a new startx.

The xf86-video-vesa driver also exhibits this very same issue (the VESA BIOS is from an Asrock mainboard).

Switching to a different virtual terminal could be useful though: try hitting Ctrl-Alt-F1 and then Ctrl-Alt-F9 after a few seconds.
When I did that on my test box, the Xorg output was displayed correctly. Xorg is usually on VT9 when launched with startx.

Our drm/i915 driver still has around 14,000 lines of differences with the Linux 3.8.13 version so I probably won't find the bug soon but I hope this workaround will be of some help in the meantime.

Actions #4

Updated by jkatzmaier about 9 years ago


Thank you very much for the workaround, as that works on my system as well. I will use the workaround until this bug is fixed. I too have an ASRock motherboard, specifically the ASRock B85M Pro4 with BIOS version P2.10.


Also available in: Atom PDF