Project

General

Profile

Bug #2949

Kernel Panic: tsleep 0xffffffff81122130 nanslp 3 after running an executable on 4.6.0-RELEASE

Added by reezer almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Kernel
Target version:
-
Start date:
09/02/2016
Due date:
% Done:

0%

Estimated time:

Description

I have been trying to reproduce a Golang/FreeBSD bug on DragonFly. Interestingly it resulted in a kernel panic.

The contents of /var/crash after the panic (bzip2'ed ~33MB) can be found here:

https://nextcloud.pixelminers.net/s/wdVFo2yA5mc5cfM/download

To reproduce the panic I also attached a static binary, so no installation of Go is required. The exact command to trigger the panic was:

export GOGC=5; export GODEBUG=gctrace=2,schedtrace=100; ./doesnotexit &> doesnotexit.log.2

You don't need to be root or have any special rights.

This was on a fresh install of DragonFly running inside Virtualbox. Sadly it takes a while and doesn't always trigger it (make sure to use the above command to speed it up). The alternative outcome might be that the process goes idle. In that case interrupt it and restart.

The golang code of the binary and information on the Go/FreeBSD bug can be found here:

https://github.com/golang/go/issues/15658


Files

doesnotexit (1.96 MB) doesnotexit binary producing the crash reezer, 09/02/2016 02:03 PM

History

#1

Updated by reezer almost 3 years ago

  • Subject changed from Kernel Panic after running an executable on 4.6.0-RELEASE to Kernel Panic: tsleep 0xffffffff81122130 nanslp 3 after running an executable on 4.6.0-RELEASE
  • Category set to Kernel
#2

Updated by reezer over 2 years ago

  • Status changed from New to Closed

I can't reproduce this on DragonFly 4.6.1, so closing.

Also available in: Atom PDF