Project

General

Profile

Bug #3216

Hang in tcdrain(3) after write(3)

Added by noloader 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
11/25/2019
Due date:
% Done:

0%

Estimated time:

Description

Hi Everyone,

I'm testing some software on DragonFly. There's not much to it. It
talks to the modem, and sends an ATZ and then reads the response.
Linux, FreeBSD, NetBSD, OpenBSD and OS X are OK.

My test rig is DragonFly 5.6-RELEASE x86_64 (fully patched) with a
USR5637 modem, https://www.amazon.com/gp/product/B0013FDLM0. The modem
is located at /dev/cuaU0.

DragonFly hangs on the call to tcdrain(3). Looking at the man page I
don't see any special handling. Cf.,
http://man.dragonflybsd.org/?command=tcdrain.

Attached is the reproducer. The trace is:

% ./test.exe
Setting TIOCEXCL
Getting tty
Setting tty options
Flushing tty
Setting tty
Writing ATZ
Waiting for write <<-- call to tcdrain(fd)

Thanks.


Files

modem-read.c (2.85 KB) modem-read.c noloader, 11/25/2019 03:14 PM

History

#1

Updated by liweitianux 10 months ago

  • Status changed from New to Resolved

Duplicate of bug #3215, so close this one.

Also available in: Atom PDF