Bug #503


ac97 sound device not detected (alc655 codec)

Added by vs1 about 17 years ago. Updated about 17 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:


Hi. Are there any known bugs in detecting ac97 sound devices? It does
not detect ours at all. We tried on the 1.6.0 kernel and on the
1.7.0-preview from CVS yesterday. We loaded snd.ko module manually and
also tried loading snd_pcm with loader at boot time. If I understand
correctly, snd_pcm is the one that handles the ac97 devices.

Every time we load the snd module, we also get this error
fdc0: cannot reserve interrupt line
printed about 6 or 7 times to the system log

When I cat /dev/sndstat, this is all I get:
FreeBSD Audio Driver (newpcm)
Installed devices:

The sound works fine on NetBSD. NetBSD reports that it is an ALC655
codec using IRQ 10.

We looked in the sys/dev/sound/pcm/ac97.c file and that codec is listed
in the ac97_codecid structure.

Any suggestions?

Actions #1

Updated by vs1 about 17 years ago

Thank you! That got it working. Now we can watch our movies on
Dragonfly! We have been evaluating Dragonfly and, so far, it is very
impressive. mplayer seems to play videos a lot smoother on a 1.3Gig
machine (even with KDE running) than NetBSD does on our 2.6Gig box.
I wonder if it is because of Matt's new LWKT code.

I had to directly load the snd_via8233.ko module. It turns out that
snd.ko was apparently loading all the sound modules except for two.
snd_via8233.ko and snd_uaudio.ko. I thought it was loading all of them.
Here is output of kldstat after loading snd.ko.

Id Refs Address Size Name
1 28 0xc0100000 60cf58 kernel
2 1 0xc070d000 37c4 md.ko
3 1 0xc0711000 590f0 acpi.ko
31 1 0xd7181000 2000 snd.ko
32 23 0xd8a80000 18000 snd_pcm.ko
33 1 0xd79ea000 4000 snd_ad1816.ko
34 1 0xd8760000 4000 snd_als4000.ko
35 1 0xd89f7000 5000 snd_cmi.ko
36 1 0xd8ab8000 5000 snd_cs4281.ko
37 1 0xd8abd000 7000 snd_csa.ko
38 1 0xd8ad9000 b000 snd_ds1.ko
39 1 0xd8ac4000 7000 snd_emu10k1.ko
40 1 0xd8ace000 6000 snd_es137x.ko
41 1 0xd8a0c000 4000 snd_fm801.ko
42 1 0xd8ae4000 5000 snd_ich.ko
43 1 0xd8ae9000 7000 snd_maestro.ko
44 1 0xd8afc000 8000 snd_maestro3.ko
45 1 0xd8b35000 a000 snd_mss.ko
46 1 0xd8b3f000 10000 snd_neomagic.ko
47 1 0xd8b4f000 5000 snd_solo.ko
48 1 0xd8b54000 5000 snd_t4dwave.ko
49 1 0xd8a1c000 4000 snd_via82c686.ko
50 1 0xd8b59000 5000 snd_vibes.ko
51 4 0xd8b09000 4000 snd_sbc.ko
52 1 0xd8b5e000 4000 snd_sb16.ko
53 1 0xd8b62000 4000 snd_sb8.ko
54 1 0xd8b66000 5000 snd_ess.ko

So the question is, why did snd.ko not load two of the modules? It is
just my luck that it happens to be the one for our sound device. Is
that a bug or a feature?

Also, we have not found any documentation that lists what devices are
supported for each module? Does it exist? The snd/pcm man page lists
AC97 mixer and a variety of cards it supports, which led us to think
that that might me the only module needed for this device. It does not
seem to mention anything about the other snd modules.

Actions #2

Updated by vs1 about 17 years ago

Thanks for the reply. As I mentioned, we loaded snd.ko, which loads all
the sound drivers, and it was not detected. Here is the output of
pciconf -lv.

none2@pci0:17:5: class=0x040100 card=0xa0021458 chip=0x30591106
rev=0x50 hdr=0x00
vendor = 'VIA Technologies Inc'
device = 'VT8233/33A/8235/8237 AC97 Enhanced Audio Controller'
class = multimedia
subclass = audio

Actions #3

Updated by bastyaelvtars about 17 years ago

On 04 Jan 2007 15:58:05 GMT
Vincent <> wrote:

No, you must load the module for your sound driver AND snd (according to corecode). There was such a thread in users@:

with the very same chip.

Actions #4

Updated by wa1ter about 17 years ago

Very interesting. You just solved a puzzle for me. I tried compiling
the 'pcm' device into my custom kernel -- which never worked! I always
had to load the via8233 module manually at boot, and now I know why.
(My SWAG would be that this is more buggish than featurish.)

Just as a minor aside, loading the via module will automatically pull in
the snd_pcm module, so you needn't load it explicitly. As a more major
aside, I do not load the snd module at all, and yet my sound works fine.

Can you try loading only the snd_via8233.ko from loader.conf and see if
you get satisfactory sound? What other modules get loaded when you try


Actions #5

Updated by corecode about 17 years ago

Does it work as expected using latest -DEVEL?

Actions #6

Updated by vs1 about 17 years ago

Ok. Just thought I would give you a status update. I finally retrieved the
repository and compiled the latest 1.7.0-DEVELOPMENT branch. Looks promising.
I loaded the new snd_driver top level module and the via8233 module did indeed
get loaded. It looks like the problem may be fixed in the DEVEL branch.

The machine that has the test installation of Dragonfly is not the one that has
the sound card that needed that driver. We have to pull the drive with
Dragonfly on it and put it back into the other machine temporarily to do the
final test to make sure the sound actually works out of the box by loading

I will post the result, probably in the next day or two, after we get a chance
to do that.

- Vincent

Actions #7

Updated by vs1 about 17 years ago

Sorry about taking so long to get back. We finally got it all tested
out in the other machine and it worked great. We also tested recording
and it worked as well. So, I apparently with the 1.7.0-DEVELOPMENT
kernel, the issue is resolved.


- Vincent

Actions #8

Updated by TGEN about 17 years ago

As noted by the bug creator, the issue has been resolved in HEAD.


Also available in: Atom PDF