Project

General

Profile

Actions

Bug #783

closed

umount issue with NTFS filesystems

Added by qermit over 14 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

qbot# mount
/dev/ad0s4a on / (ufs, local)
procfs on /proc (procfs, local)
/dev/ad0s5 on /mnt/aparat (ntfs, local)

if I umount by path (/mnt/aparat) my box reboots
if I umount by device (/dev/ad0s5) it's ok

Actions #1

Updated by dillon over 14 years ago

:New submission from qermit <>:
:
:qbot# mount
:/dev/ad0s4a on / (ufs, local)
:procfs on /proc (procfs, local)
:/dev/ad0s5 on /mnt/aparat (ntfs, local)
:
:if I umount by path (/mnt/aparat) my box reboots
:if I umount by device (/dev/ad0s5) it's ok

Its really hard for me to test ntfs.  Could you format a small ntfs
filesystem on, say, a usb memory stick, which reproduces the crashing
problem, and then dump an image of that filesystem and make it available
for download? I have no way of constructing a ntfs filesystem myself.
-Matt
Actions #2

Updated by floid over 14 years ago

Looks like there's a mkntfs is available in /usr/pkgsrc/sysutils/ntfsprogs
(Linux-NTFS.org tools), and I did the sanity-check of making sure it builds
before saying so.

-Cheers,
-Joe "Floid" Kanowitz

Actions #3

Updated by tuxillo over 12 years ago

Hi,

I can't reproduce this:

grep ntfs /etc/fstab

/dev/ad3s1 /mnt/ntfs ntfs ro 0 0

sudo mount /mnt/ntfs
mount -v | grep ntfs

/dev/ad3s1 on /mnt/ntfs (ntfs, local, read-only)

sudo umount /mnt/ntfs/
mount -v | grep ntfs

Can you please give us more details on how to reproduce it?

Cheers,
Antonio Huete

Actions #4

Updated by alexh over 11 years ago

likely related to issue1671, which is fixed.

Actions

Also available in: Atom PDF