Project

General

Profile

Actions

Bug #945

closed

linux_getdents trouble

Added by samflanker almost 14 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Hi

program-test (experimental) for testing syscall linux_getdents()
http://cs.udmvt.ru/files/temp/linux_dbg.tar.bz2
includes:
  • temp/ - test_dir with files (special for crash situation)
  • linux_getdents.c - source of program-test
  • linux_getdents_static - binary exec file, staticaly compiled on Linux
    Debian 4.0 Etch
  • linux_getdents_dynamic - binary exec file, dynamicaly compiled on
    Linux Debian 4.0 Etch

/Vladimir Ermakov

Actions #1

Updated by gstanley over 13 years ago

This is not a bug in emulation; it's a bug with glibc under linux emulation.

Actions #2

Updated by corecode over 13 years ago

Shouldn't we anyways try to fix that?

cheers
simon

Actions #3

Updated by gstanley over 13 years ago

I was able to 'correct' it on freebsd by doing a glibc update to a newer
version, it doesn't occur anymore. Perhaps there is a bug somewhere in the
getdents handling in emulation..

Actions #4

Updated by tuxillo over 12 years ago

I can't grab the test program. Is it still available anywhere?

Actions

Also available in: Atom PDF