Bug #1287

altq configuration doesn't work

Added by corecode about 5 years ago. Updated 2 months ago.

Status:FeedbackStart date:
Priority:NormalDue date:
Assignee:tuxillo% Done:

0%

Category:Networking
Target version:3.8.0

Description

There seem to be serious issues with ALTQ.

Just now I tried to disable it, by removing altq queue definitions from pf.conf
+ resync, by disabling pf and also by flushing all pf data. Nevertheless it
kept on doing bandwidth shaping. Had to reboot to get rid of this.

Also I had the feeling that changing the altq queue parameters + resync did not
have any effect on the queueing behavior (changed from 560kbps -> 5kbps), but I
could be mistaken in that regard.

History

#1 Updated by tuxillo 2 months ago

  • Description updated (diff)
  • Category set to Networking
  • Assignee changed from 0 to tuxillo
  • Target version set to 3.8.0

Grab.

#2 Updated by tuxillo 2 months ago

  • Status changed from New to Feedback

Hi,

I've been playing around a bit with ALTQ on a VM with a very simple config and a 1GB test file called test.img.

altq on em0 cbq bandwidth 5Mb queue { std }
queue std bandwidth 2Mb cbq(default)
pass out on em0 proto tcp queue std

For the test I connected to the dragonfly VM SFTP service using Filezilla and tried to download test.img.
Changing queue bandwidth (setting it to 200Kb, 1500Kb, 3Mb, ...) and using '/etc/rc.d/pf resync' or '/etc/rc.d/pf reload' I could see how the download speed changed.
So I guess this might not be valid anymore.

Anyways, let us know if you used different settings or queues.

Cheers,
Antonio Huete

Also available in: Atom PDF