Bug #1595

Boot try to continue even when I specify ufs in mountroot> when I have Hammer FS used

Added by bodie about 5 years ago. Updated over 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

I'm trying to use loader prompt to boot from disk. Installation was with Hammer
FS and step with Install boot blocks was skipped. I must turn off ACPI thanks to
another bug. Boot from HDD will start but after sometime it shows mountroot>
prompt and asks for specification of root fs. If I choose Hammer FS on any
available partition then nothing. If I choose ufs:ad4s2a then I get kernel panic
in attachment. If I type abort to continue without manual specification I get
another kernel panic which will be in another bug.

03112009566.jpg (442 KB) bodie, 11/03/2009 03:11 PM

03112009570.jpg (446 KB) bodie, 11/03/2009 06:52 PM

History

#1 Updated by corecode about 5 years ago

Tomas Bodzar (via DragonFly issue tracker) wrote:
> New submission from Tomas Bodzar <>:
>
> I'm trying to use loader prompt to boot from disk. Installation was with Hammer
> FS and step with Install boot blocks was skipped. I must turn off ACPI thanks to
> another bug. Boot from HDD will start but after sometime it shows mountroot>
> prompt and asks for specification of root fs. If I choose Hammer FS on any
> available partition then nothing. If I choose ufs:ad4s2a then I get kernel panic
> in attachment. If I type abort to continue without manual specification I get
> another kernel panic which will be in another bug.

So it does not work if you specify

hammer:ad4s2d

is that correct?

#2 Updated by bodie about 5 years ago

Yes, it doesn't work when I specify hammer:ad4s2d

#3 Updated by corecode about 5 years ago

Tomas Bodzar (via DragonFly issue tracker) wrote:
> Tomas Bodzar <> added the comment:
>
> Yes, it doesn't work when I specify hammer:ad4s2d

Can we see a picture of "it doesn't work"?

#4 Updated by bodie about 5 years ago

I'm able to boot with hammer:ad4s2d now. All other options shows error in
attachment. I thought, that root file systems are on a partition.

Sequence to boot from HDD trough CD installer was : unload ; lsdev ; set
currdev="disk0s2a" ; unset acpi_load ; set hint.acpi.0.disable="1" ; boot

#5 Updated by corecode about 5 years ago

Tomas Bodzar (via DragonFly issue tracker) wrote:
> Tomas Bodzar <> added the comment:
>
> I'm able to boot with hammer:ad4s2d now. All other options shows error in
> attachment. I thought, that root file systems are on a partition.

ad4s2d

#6 Updated by alexh about 5 years ago

So everything works? Can this be closed?

Also available in: Atom PDF