Bug #1779

DragonFly v2.7.3.70.g07b6d - panic: IP header not in one mbuf

Added by tuxillo about 4 years ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:tuxillo% Done:

0%

Category:Networking
Target version:3.8.0

Description

Hi,

I got this in a machine running the DFBSD version specified in the title of this
ticket. See below the backtrace. Kernel core is in my home dir (~/crash/ipheader*.3)

panic: IP header not in one mbuf
Trace beginning at frame 0xcfe19c08
panic(ffffffff) at panic+0x8e
panic(c05c059b,c2c89e00,14,0,1) at panic+0x8e
ip_input(d2644800) at ip_input+0xb5
ip_input_handler(d2644818) at ip_input_handler+0xe
netisr_run(2,d2644800) at netisr_run+0x7d
ether_demux_oncpu(c2c89e00,d2644800) at ether_demux_oncpu+0x298
ether_input_oncpu(c2c89e00,d2644800) at ether_input_oncpu+0x95
ether_input_handler(d2644818,c06f7318,c06f7318,cfe19d84,c03dbcbf) at
ether_input_handler+0x102
netmsg_service(d2644818,1,0,c06f6f80,ff800000) at netmsg_service+0x4a
tcpmsg_service_loop(0,0,0,0,0) at tcpmsg_service_loop+0x1d
lwkt_exit() at lwkt_exit
Debugger("panic")
panic: from debugger
Uptime: 10h50m27s
Physical memory: 1003 MB
Dumping 287 MB: 272 256 240 224 208 192 176 160 144 128 112 96 80 64 48 32 16

(kgdb) bt
#0 _get_mycpu (di=0xc06bbf80) at ./machine/thread.h:83
#1 md_dumpsys (di=0xc06bbf80) at
/home/source/dfbsd/sys/platform/pc32/i386/dump_machdep.c:263
#2 0xc03178f6 in dumpsys () at /home/source/dfbsd/sys/kern/kern_shutdown.c:838
#3 0xc0317e71 in boot (howto=260) at
/home/source/dfbsd/sys/kern/kern_shutdown.c:387
#4 0xc0317f97 in panic (fmt=0xc05a09ea "from debugger") at
/home/source/dfbsd/sys/kern/kern_shutdown.c:744
#5 0xc01765e9 in db_panic (addr=-1068218104, have_addr=0, count=-1,
modif=0xcfe19ac0 "")
at /home/source/dfbsd/sys/ddb/db_command.c:448
#6 0xc0176c5e in db_command () at /home/source/dfbsd/sys/ddb/db_command.c:344
#7 db_command_loop () at /home/source/dfbsd/sys/ddb/db_command.c:470
#8 0xc0179260 in db_trap (type=3, code=0) at
/home/source/dfbsd/sys/ddb/db_trap.c:71
#9 0xc0544a74 in kdb_trap (type=3, code=0, regs=0xcfe19bb8)
at /home/source/dfbsd/sys/platform/pc32/i386/db_interface.c:152
#10 0xc0556d27 in trap (frame=0xcfe19bb8) at
/home/source/dfbsd/sys/platform/pc32/i386/trap.c:837
#11 0xc0545e47 in calltrap () at
/home/source/dfbsd/sys/platform/pc32/i386/exception.s:785
#12 0xc0544908 in breakpoint (msg=0xc05b88ec "panic") at ./cpu/cpufunc.h:73
#13 Debugger (msg=0xc05b88ec "panic") at
/home/source/dfbsd/sys/platform/pc32/i386/db_interface.c:334
#14 0xc0317f8e in panic (fmt=0xc05c059b "IP header not in one mbuf")
at /home/source/dfbsd/sys/kern/kern_shutdown.c:742
#15 0xc03d082a in ip_input (m=0xd2644800) at
/home/source/dfbsd/sys/netinet/ip_input.c:481
#16 0xc03d140d in ip_input_handler (msg0=0xd2644818) at
/home/source/dfbsd/sys/netinet/ip_input.c:434
#17 0xc0392a5a in netisr_run (num=2, m=0xd2644800) at
/home/source/dfbsd/sys/net/netisr.c:590
#18 0xc0388b6b in ether_demux_oncpu (ifp=0xc2c89e00, m=0xd2644800) at
/home/source/dfbsd/sys/net/if_ethersubr.c:1365
#19 0xc0388c0b in ether_input_oncpu (ifp=0xc2c89e00, m=0xd2644800) at
/home/source/dfbsd/sys/net/if_ethersubr.c:1424
#20 0xc0388d15 in ether_input_handler (nmsg=0xd2644818) at
/home/source/dfbsd/sys/net/if_ethersubr.c:1532
#21 0xc039275c in netmsg_service (msg=0xc071b12c, mpsafe_mode=1, mplocked=0)
at /home/source/dfbsd/sys/net/netisr.c:303
#22 0xc03dbcbf in tcpmsg_service_loop (dummy=0x0) at
/home/source/dfbsd/sys/netinet/tcp_subr.c:410
#23 0xc031f3aa in lwkt_deschedule_self (td=Cannot access memory at address 0x8
) at /home/source/dfbsd/sys/kern/lwkt_thread.c:250
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

History

#1 Updated by tuxillo over 1 year ago

  • Status changed from New to In Progress
  • Assignee changed from 0 to tuxillo

Grab

#2 Updated by tuxillo 5 months ago

  • Description updated (diff)
  • Category set to Networking
  • Status changed from In Progress to Closed
  • Target version set to 3.8.0

Hi,

Couldn't reproduce. Many fixes went in after this was reported.

Cheers,
Antonio Huete

Also available in: Atom PDF