Bug #2022

wget core dumped

Added by ufs almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:
Priority:LowDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

# wget http://znc.in/releases/znc-0.096.tar.gz
--2011-03-08 23:50:27-- http://znc.in/releases/znc-0.096.tar.gz
Segmentation fault(core dumped)

# gdb `which wget` wget.core
GNU gdb (GDB) 7.0
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-dragonfly".
For bug reporting instructions, please see:
<http://bugs.dragonflybsd.org/&gt;...
Reading symbols from /usr/pkg/bin/wget...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libssl.so.5...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libssl.so.5
Reading symbols from /usr/lib/libcrypto.so.5...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libcrypto.so.5
Reading symbols from /usr/pkg/lib/libintl.so.3...(no debugging symbols
found)...done.
Loaded symbols for /usr/pkg/lib/libintl.so.3
Reading symbols from /usr/pkg/lib/libidn.so.11...(no debugging symbols
found)...done.
Loaded symbols for /usr/pkg/lib/libidn.so.11
Reading symbols from /usr/lib/libc.so.7...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libc.so.7
Reading symbols from /usr/lib/i18n/libiconv_std.so.1...(no debugging symbols
found)...done.
Loaded symbols for /usr/lib/i18n/libiconv_std.so.1
Reading symbols from /usr/lib/i18n/libUTF8.so.1...(no debugging symbols
found)...done.
Loaded symbols for /usr/lib/i18n/libUTF8.so.1
Reading symbols from /usr/lib/i18n/libmapper_parallel.so.1...(no debugging
symbols found)...done.
Loaded symbols for /usr/lib/i18n/libmapper_parallel.so.1
Reading symbols from /usr/lib/i18n/libmapper_std.so.1...(no debugging symbols
found)...done.
Loaded symbols for /usr/lib/i18n/libmapper_std.so.1
Reading symbols from /usr/libexec/ld-elf.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/libexec/ld-elf.so.2
Core was generated by `wget'.
Program terminated with signal 11, Segmentation fault.
#0 0x0000000800ab27e4 in libintl_dcigettext () from /usr/pkg/lib/libintl.so.3
(gdb)

History

#1 Updated by ftigeot almost 4 years ago

[...]
> Program terminated with signal 11, Segmentation fault.
> #0 0x0000000800ab27e4 in libintl_dcigettext () from /usr/pkg/lib/libintl.so.3
> (gdb)

This is strangely similar to an issue which was fixed a few month ago:

http://gnats.netbsd.org/cgi-bin/query-pr-single.pl?number=43879

I guess you are running an x86_64 system.
What is your version of gettext-lib ?

#2 Updated by ufs almost 4 years ago

gettext-lib-0.14.6

thnx, let's try)

#3 Updated by ftigeot almost 4 years ago

On Sun, Mar 13, 2011 at 07:35:33PM +0000, Artem Gutman (via DragonFly issue tracker) wrote:
>
> Artem Gutman <> added the comment:
>
> gettext-lib-0.14.6
>
> thnx, let's try)

Crap, the revision of gettext-lib wasn't bumped when it was fixed.

Do you know from which pkgsrc release you installed it ?

Is there a line
USE_TOOLS+= autoconf
in the Makefile ?

Is there a file patch-ac in patches/ ?

#4 Updated by ufs almost 4 years ago

Yep, pkgsrc release is pkgsrc-2010Q4.

Is there a line
USE_TOOLS+= autoconf
in the Makefile ?
There is no such line in a file

Is there a file patch-ac in patches/ ? Yes. patch-aa, patch-ab, patch-ac.

#5 Updated by ftigeot almost 4 years ago

On Sun, Mar 13, 2011 at 08:13:24PM +0000, Artem Gutman (via DragonFly issue tracker) wrote:
>
> Artem Gutman <> added the comment:
>
> Yep, pkgsrc release is pkgsrc-2010Q4.
>
> Is there a line
> USE_TOOLS+= autoconf
> in the Makefile ?
> There is no such line in a file

This is good.

> Is there a file patch-ac in patches/ ? Yes. patch-aa, patch-ab, patch-ac.

And this is bad. You do not have the latest version of gettext-lib.

In the end, the correct fix for the bug you are seeing was to remove patch-ac;
it was done in this commit back in October 2010:

http://cvsweb.de.netbsd.org/cgi-bin/cvsweb.cgi/pkgsrc/devel/gettext-lib/Makefile?only_with_tag=pkgsrc-2010Q4

If this file is present in your pkgsrc tree, you can't possibly be using the
real pkgsrc-2010Q4 version.

Please upgrade to pkgsrc-2010Q4 and reinstall devel/gettext-lib

If you still have the patch-ac file afterwards, it will be time to open a new
bug report and find out why you didn't get the real pkgsrc-2010Q4 tree.

#6 Updated by ufs almost 4 years ago

> lease upgrade to pkgsrc-2010Q4 and reinstall devel/gettext-lib
Khmm, I have already pkgsrc-2010Q4.
That that here is explicit not that :-) I will try, write anyway, thanks!

#7 Updated by ufs almost 4 years ago

# bmake pkgsrc-update
cd /usr/pkgsrc && git pull
Already up-to-date.
wget [OPTION]... [URL]...

It works!
I have deleted patch.ac and have reinstalled port with dependences, have helped.

#8 Updated by ftigeot almost 4 years ago

On Sun, Mar 13, 2011 at 08:55:10PM +0000, Artem Gutman (via DragonFly issue tracker) wrote:
>
> Artem Gutman <> added the comment:
>
> # bmake pkgsrc-update
> cd /usr/pkgsrc && git pull
> Already up-to-date.
> wget [OPTION]... [URL]...
>
> It works!
> I have deleted patch.ac and have reinstalled port with dependences, have helped.

Glad to be of some help :)

You had to delete patch-ac manually, make pkgsrc-update didn't remove the
file. Is that right ?

Also available in: Atom PDF