Bug #2175

panic: syscall: extra tokens held after trap! 1

Added by swildner about 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

While running stress2's syscall tests, I got a panic (i386, UP, latest master).
Dump is in ~swildner/crash/crash5.txz on leaf. Some more data:

Unread portion of the kernel message buffer:
panic: syscall: extra tokens held after trap! 1
Trace beginning at frame 0xd9987c94
panic(ffffffff,c07f7420,c07043cc,d9987cc4,d9832278) at panic+0x101
panic
(c07043cc,1,c,d9832278,0,3,c076fa9c,1e55,293,0,16,d6455e60,0,2809cda7,d9987d40,d9987d20,2809cda7,2e39bf4e,861b7b8e,bfbff47c,0,0,d6455e60,0,115,bfbff494)
at panic+0x101
syscall2(d9987d40) at syscall2+0x3eb
Xint0x80_syscall() at Xint0x80_syscall+0x36
Debugger("panic")

Backtrace:

(kgdb) bt
#0 _get_mycpu () at ./machine/thread.h:79
#1 md_dumpsys (di=0xc07f7540)
at /usr/src/sys/platform/pc32/i386/dump_machdep.c:264
#2 0xc036ea40 in dumpsys () at /usr/src/sys/kern/kern_shutdown.c:925
#3 0xc018a55a in db_fncall (dummy1=-1067406430, dummy2=0, dummy3=-1072124853,
dummy4=0xd9987b28 "\304r`\300\016\061h\300")
at /usr/src/sys/ddb/db_command.c:542
#4 0xc018aa3f in db_command (aux_cmd_tablep_end=0xc070b978,
aux_cmd_tablep=0xc070b95c, cmd_table=<optimized out>,
last_cmdp=<optimized out>) at /usr/src/sys/ddb/db_command.c:344
#5 db_command_loop () at /usr/src/sys/ddb/db_command.c:470
#6 0xc018d57e in db_trap (type=3, code=0) at /usr/src/sys/ddb/db_trap.c:71
#7 0xc060aed8 in kdb_trap (type=3, code=0, regs=0xd9987c44)
at /usr/src/sys/platform/pc32/i386/db_interface.c:152
#8 0xc06309b7 in trap (frame=0xd9987c44)
at /usr/src/sys/platform/pc32/i386/trap.c:831
#9 0xc060c327 in calltrap ()
at /usr/src/sys/platform/pc32/i386/exception.s:787
#10 0xc060aba2 in breakpoint () at ./cpu/cpufunc.h:72
#11 Debugger (msg=0xc069cabd "panic")
at /usr/src/sys/platform/pc32/i386/db_interface.c:334
#12 0xc036f1ab in panic (
fmt=0xc07043cc "syscall: extra tokens held after trap! %zd")
at /usr/src/sys/kern/kern_shutdown.c:822
#13 0xc0631066 in syscall2 (frame=0xd9987d40)
at /usr/src/sys/platform/pc32/i386/trap.c:1407
#14 0xc060c3d6 in Xint0x80_syscall ()
at /usr/src/sys/platform/pc32/i386/exception.s:878
#15 0x0000001f in ?? ()

History

#1 Updated by swildner almost 3 years ago

  • Status changed from New to Closed

Closing this as I can't reproduce it with latest.

Also available in: Atom PDF