Bug #239

Latest Sun java/linux binaries segfault on DF

Added by wa1ter about 8 years ago. Updated about 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

While trying to update the pkgsrc/lang/sun-jre14 package to use
the most recent linux-jre14 binaries from Sun, I found that all
of the Sun linux binaries will segfault on DF-current with a
"Bad system call' error. (E.g. 'java -version' dumps core.)

This is brand new with j2re-1_4_2_12-linux-i586.bin, and does
not affect either NetBSD-current or FreeBSD-current.

The previous package, j2re-1_4_2_11-linux-i586.bin, works very
well on DragonFly, so Sun did something different with their
latest release that DF doesn't like. (This also applies to
the Sun jdk14-linux, by the way.)

Can anyone here confirm this problem? I have only DF-current
available, so what about you guys running earlier DF versions?

History

#1 Updated by schlesinger almost 8 years ago

Problem does still exist with sun-jre15-5.0.8nb1.

#2 Updated by pavalos about 5 years ago

Essentially, this is a duplicate of issue 1141. Our linuxulator is severely
out of date.

Also available in: Atom PDF