Bug #2500

DFBSD 3.3.0: page fault with iwn and wpa_supplicant

Added by tincman over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:01/27/2013
Priority:NormalDue date:
Assignee:sepherosa% Done:

0%

Category:-
Target version:-

Description

On 3.3 (tested with x86_64 snapshots 3.3.0.1011.gf30b8 and 3.3.0.960.g553fe7) starting wpa_supplicant with an iwn card causes a page fault.

Tested on two Lenovo Thinkpads (X301 and SL500), both with an Intel Pro/Wireless 5100 AGN. Both work under 3.2-RELEASE.

Page fault message attached, currently attempting regression tests with previous snapshots.

iwn_wpa.txt Magnifier (630 Bytes) tincman, 01/27/2013 09:29 AM

History

#1 Updated by sepherosa over 1 year ago

On Mon, Jan 28, 2013 at 1:28 AM, Scott Tincman via Redmine
<> wrote:
>
> Issue #2500 has been reported by tincman.
>
> ----------------------------------------
> Bug #2500: DFBSD 3.3.0: page fault with iwn and wpa_supplicant
> http://bugs.dragonflybsd.org/issues/2500
>
> Author: tincman
> Status: New
> Priority: Normal
> Assignee:
> Category:
> Target version:
>
>
> On 3.3 (tested with x86_64 snapshots 3.3.0.1011.gf30b8 and 3.3.0.960.g553fe7) starting wpa_supplicant with an iwn card causes a page fault.
>
> Tested on two Lenovo Thinkpads (X301 and SL500), both with an Intel Pro/Wireless 5100 AGN. Both work under 3.2-RELEASE.
>
> Page fault message attached, currently attempting regression tests with previous snapshots.

Should have been fixed at:
c332e0e8d3bc067a075fa42c1e3896f875c99b82

If you still have trouble, please let me know.

Best Regards,
sephe

>
>
> --
> You have received this notification because you have either subscribed to it, or are involved in it.
> To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

--
Tomorrow Will Never Die

#2 Updated by tincman over 1 year ago

sepherosa wrote:
> On Mon, Jan 28, 2013 at 1:28 AM, Scott Tincman via Redmine
> <> wrote:
> >
> > Issue #2500 has been reported by tincman.
> >
> > ----------------------------------------
> > Bug #2500: DFBSD 3.3.0: page fault with iwn and wpa_supplicant
> > http://bugs.dragonflybsd.org/issues/2500
> >
> > Author: tincman
> > Status: New
> > Priority: Normal
> > Assignee:
> > Category:
> > Target version:
> >
> >
> > On 3.3 (tested with x86_64 snapshots 3.3.0.1011.gf30b8 and 3.3.0.960.g553fe7) starting wpa_supplicant with an iwn card causes a page fault.
> >
> > Tested on two Lenovo Thinkpads (X301 and SL500), both with an Intel Pro/Wireless 5100 AGN. Both work under 3.2-RELEASE.
> >
> > Page fault message attached, currently attempting regression tests with previous snapshots.
>
> Should have been fixed at:
> c332e0e8d3bc067a075fa42c1e3896f875c99b82
>
> If you still have trouble, please let me know.
>
> Best Regards,
> sephe
>
> >
> >
> > --
> > You have received this notification because you have either subscribed to it, or are involved in it.
> > To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account
>
>
>
> --
> Tomorrow Will Never Die

Yes, that commit did the trick.

Thank you :]

Tincman

#3 Updated by pavalos over 1 year ago

  • Status changed from New to Closed
  • Assignee set to sepherosa

Also available in: Atom PDF