Bug #2538

mkisofs hardlink detection broken on HAMMER

Added by swildner over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:04/06/2013
Priority:NormalDue date:
Assignee:swildner% Done:

0%

Category:-
Target version:-

Description

Running mkisofs on a directory with hard links will count each hard link as a separate file when that directory is on a HAMMER file system and the .iso will be larger than if the directory had been on a UFS. It seems mkisofs's hard link detection (it goes by identical inodes, I guess) isn't working on HAMMER.

A very unpleasant side effect of this is that our ISOs are much larger than they could be. In fact, the x86_64 ISO is already exceeding the 750MB mark. This is because /usr/pkg/libexec/git-core has a large number of hard links (over 100) for a >2MB file.

I don't think HAMMER is really at fault here and the only thing I can think of right now (without having looked at cdrtools source) is that it could have to do with HAMMER's inodes being 64 bit (?) vs. 32 on UFS.

Regards,
Sascha

History

#1 Updated by swildner over 1 year ago

  • Assignee set to swildner

Further testing results are inconclusive yet and we're still checking out under which circumstances the issue is present.

#2 Updated by swildner over 1 year ago

  • Status changed from New to Closed

Disregard what I wrote.

Mkisofs is fine and I let myself get fooled by wrongly calculating what takes which space on the ISO.

Also available in: Atom PDF