Project

General

Profile

Bug #2614

[PATCH][dports] devel/cmake fail to fetch

Added by kAworu almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/16/2013
Due date:
% Done:

0%


Description

Steps to reproduce:
<pre>
# rm -f /usr/distfiles/cmake-2.8.12.1.tar.gz
# make -C /usr/dports/devel/cmake fetch
===> License BSD accepted by the user
===> cmake-2.8.12.1 depends on file: /usr/local/sbin/pkg - found
=> cmake-2.8.12.1.tar.gz doesn't seem to exist in /usr/distfiles/.
=> Attempting to fetch http://www.cmake.org/files/v2.8/cmake-2.8.12.1.tar.gz
fetch: http://www.cmake.org/files/v2.8/cmake-2.8.12.1.tar.gz: Moved Temporarily
=> Attempting to fetch ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/cmake-2.8.12.1.tar.gz
fetch: ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/cmake-2.8.12.1.tar.gz: File unavailable (e.g., file not found, no access)
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/distfiles/ and try again.
*** Error code 1

Stop.
make: stopped in /usr/dports/devel/cmake
</pre>

0001-devel-cmake-Fix-MASTER_SITES.patch View (686 Bytes) kAworu, 12/16/2013 01:12 PM

History

#1 Updated by kAworu almost 3 years ago

About the attached patch, I've taken the MASTER_SITES from FreeBSD port and build / installed successfully cmake.

#2 Updated by marino almost 3 years ago

two comments:

1) dports issues are intended to be reported at: https://github.com/DragonFlyBSD/DPorts/issues not here
2) This is an issue for ports, not dports. It should be reported at http://www.freebsd.org/send-pr.html

A global breakage across ports is not something I normally patch. We get it fixed at FreeBSD ports level and let the fix trickle back.

#3 Updated by kAworu almost 3 years ago

  • Status changed from New to Closed

marino wrote:
> two comments:
>
> 1) dports issues are intended to be reported at: https://github.com/DragonFlyBSD/DPorts/issues not here
> 2) This is an issue for ports, not dports. It should be reported at http://www.freebsd.org/send-pr.html
>
> A global breakage across ports is not something I normally patch. We get it fixed at FreeBSD ports level and let the fix trickle back.

Alright for both 1) and 2), since it is already fixed upstream I guess waiting is the way to go. I am closing this issue then and will report the next dport related one to the appropriate GitHub repository, thank you for your time.

Also available in: Atom PDF