Project

General

Profile

Bug #1063

keyboard doesn't work on -DEVEL snapshot

Added by polachok about 12 years ago. Updated almost 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

I got the latest snapshot and tried to install DragonFly, but my
laptop's keyboard doesn't work. So, I installed via qemu and tried to
boot in real machine. Here is dmesg (ACPI-enabled, I can provide ACPI-disabled if
needed). Also, I'll try FreeBSD snapshot in a couple of hours and
report if it works.

Copyright (c) 2003-2008 The DragonFly Project.
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
DragonFly 1.13.0-DEVELOPMENT #0: Wed Jul 9 00:54:07 CEST 2008
:/usr/obj/usr/src/sys/GENERIC
TSC clock: 799989887 Hz, i8254 clock: 1193167 Hz
CPU: Mobile AMD Sempron(tm) Processor 3300+ (800.01-MHz 686-class CPU)
Origin = "AuthenticAMD" Id = 0x20fc2 Stepping = 2
Features=0x78bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2>
Features2=0x1<SSE3>
AMD Features=0xc0500000<NX,AMIE,DSP,3DNow!>
real memory = 468320256 (457344K bytes)
avail memory = 440774656 (430444K bytes)
Preloaded elf kernel "/kernel" at 0xc0843000.
Preloaded elf module "/modules/acpi.ko" at 0xc0843288.
Pentium Pro MTRR support enabled
md0: Malloc disk
pcibios: BIOS version 2.10
ACPI: RSDP @ 0x0xf7ed0/0x0014 (v 0 PTLTD )
ACPI: RSDT @ 0x0x1beaa446/0x0034 (v 1 PTLTD RSDT 0x06040000 LTP 0x00000000)
ACPI: FACP @ 0x0x1beaedff/0x0074 (v 1 FUJ W37 0x06040000 W37 0x000F4240)
ACPI: DSDT @ 0x0x1beaa47a/0x4985 (v 1 FUJ W37 0x06040000 MSFT 0x0100000E)
ACPI: FACS @ 0x0x1beaffc0/0x0040
ACPI: SSDT @ 0x0x1beaee73/0x00F7 (v 1 PTLTD POWERNOW 0x06040000 LTP 0x00000001)
ACPI: APIC @ 0x0x1beaef6a/0x005A (v 1 PTLTD APIC 0x06040000 LTP 0x00000000)
ACPI: MCFG @ 0x0x1beaefc4/0x003C (v 1 PTLTD MCFG 0x06040000 LTP 0x00000000)
sched_ithd: stray interrupt 7 on cpu 0
npx0: <math processor> on motherboard
npx0: INT 16 interface
Using XMM optimized bcopy/copyin/copyout
acpi0: <PTLTD RSDT> on motherboard
acpi0: Power Button (fixed)
Warning: ACPI is disabling APM's device. You can't run both
acpi_ec0: <Embedded Controller: GPE 0x3> port 0x66,0x62 on acpi0
acpi_timer0: <32-bit timer at 3.579545MHz> port 0x8008-0x800b on acpi0
cpu0: <ACPI CPU (3 Cx states)> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
acpi_tz1: <Thermal Zone> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Sleep Button> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
device_probe_and_attach: atkbd0 attach returned 6
psm0: failed to get data.
psm0: failed to get status.
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._STA] (Node 0xc1988374), AE_NO_HARDWARE_RESPONSE
ACPI Error (uteval-0309): Method execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._STA] (Node 0xc1988374), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._STA] (Node 0xc1988374), AE_NO_HARDWARE_RESPONSE
ACPI Error (uteval-0309): Method execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._STA] (Node 0xc1988374), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._STA] (Node 0xc1988374), AE_NO_HARDWARE_RESPONSE
ACPI Error (uteval-0309): Method execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._STA] (Node 0xc1988374), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._STA] (Node 0xc1988374), AE_NO_HARDWARE_RESPONSE
ACPI Error (uteval-0309): Method execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._STA] (Node 0xc1988374), AE_NO_HARDWARE_RESPONSE
acpi_cmbat0: <Control Method Battery> on acpi0
acpi_acad0: <AC Adapter> on acpi0
legacypci0 on motherboard
pcib0: <Host to PCI bridge> on legacypci0
pci0: <PCI bus> on pcib0
pcib1: <PCI to PCI bridge (vendor=1002 device=5a3f)> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <ATI model 5955 graphics accelerator> at 5.0 irq 11
ohci0: <ATI SB400 USB Controller> mem 0xd0000000-0xd0000fff irq 11 at device 19.0 on pci0
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
sched_ithd: stray interrupt 7 on cpu 0
usb0: <ATI SB400 USB Controller> on ohci0
usb0: USB revision 1.0
uhub0: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 4 ports with 4 removable, self powered
ohci1: <ATI SB400 USB Controller> mem 0xd0001000-0xd0001fff irq 11 at device 19.1 on pci0
usb1: OHCI version 1.0, legacy support
usb1: SMM does not respond, resetting
sched_ithd: stray interrupt 7 on cpu 0
sched_ithd: stray interrupt 7 on cpu 0
sched_ithd: stray interrupt 7 on cpu 0
usb1: <ATI SB400 USB Controller> on ohci1
usb1: USB revision 1.0
uhub1: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
uhub1: 4 ports with 4 removable, self powered
pci0: <USB controller> at 19.2 irq 11
pci0: <unknown card> (vendor=0x1002, dev=0x4372) at 20.0
atapci0: <ATI IXP400 UDMA133 controller> port 0x8410-0x841f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 irq 11 at device 20.1 on pci0
ata0: <ATA channel 0> on atapci0
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.GBST] (Node 0xc1988234), AE_NO_HARDWARE_RESPONSE
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._BST] (Node 0xc19883c4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._BIF] (Node 0xc198839c), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.GBIF] (Node 0xc198820c), AE_NO_HARDWARE_RESPONSE
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._BIF] (Node 0xc198839c), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._BST] (Node 0xc19883c4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.GBIF] (Node 0xc198820c), AE_NO_HARDWARE_RESPONSE
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._BIF] (Node 0xc198839c), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.GBIF] (Node 0xc198820c), AE_NO_HARDWARE_RESPONSE
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._BIF] (Node 0xc198839c), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._BIF] (Node 0xc198839c), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.GBST] (Node 0xc1988234), AE_NO_HARDWARE_RESPONSE
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._BST] (Node 0xc19883c4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.GBIF] (Node 0xc198820c), AE_NO_HARDWARE_RESPONSE
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._BIF] (Node 0xc198839c), AE_NO_HARDWARE_RESPONSE
umass0: <JMicron USB to ATA/ATAPI Bridge, class 0/0, rev 2.00/1.00, addr 2> on uhub1
ukbd0: <vendor 0x04d9 USB Keyboard, class 0/0, rev 1.10/3.10, addr 2> on uhub0
kbd1 at ukbd0
uhid0: <vendor 0x04d9 USB Keyboard, class 0/0, rev 1.10/3.10, addr 2> on uhub0
ad0: 57231MB <SAMSUNG MP0603H UD100-14> at ata0-master UDMA100
ata1: <ATA channel 1> on atapci0
acd0: DVDR <HL-DT-ST DVD-RW GWA-4082N/CW02> at ata1-master UDMA33
isab0: <PCI to ISA bridge (vendor=1002 device=4377)> at device 20.3 on pci0
isa0: <ISA bus> on isab0
pcib2: <PCI to PCI bridge (vendor=1002 device=4371)> at device 20.4 on pci0
pci2: <PCI bus> on pcib2
pci2: <unknown card> (vendor=0x168c, dev=0x001a) at 5.0 irq 11
rl0: <RealTek 8139 10/100BaseTX> port 0xa000-0xa0ff mem 0xd0216000-0xd02160ff irq 7 at device 7.0 on pci2
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl0: MAC address: 00:0a:e4:b2:39:be
cbb0: <TI6411 PCI-CardBus Bridge> at device 9.0 on pci2
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
pcib2: routed slot 9 INTA to irq 255
cbb: Unable to map IRQ...
device_probe_and_attach: cbb0 attach returned 12
fwohci0: vendor=104c, dev=8032
fwohci0: <1394 Open Host Controller Interface> mem 0xd0210000-0xd0213fff,0xd0216800-0xd0216fff irq 10 at device 9.2 on pci2
fwohci0: OHCI version 1.10 (ROM=0)
fwohci0: No. of Isochronous channel is 4.
fwohci0: EUI64 00:0a:e4:05:48:10:0b:53
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
fwe0: MAC address: 02:0a:e4:10:0b:53
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: node_id=0xc800ffc0, gen=2, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
fwohci0: phy int
pci2: <unknown card> (vendor=0x104c, dev=0x8033) at 9.3 irq 11
pci0: <unknown card> (vendor=0x1002, dev=0x4370) at 20.5 irq 11
pci0: <unknown card> (vendor=0x1002, dev=0x4378) at 20.6 irq 11
orm0: <Option ROMs> at iomem 0xc0000-0xcffff,0xdc000-0xdffff on isa0
pmtimer0 on isa0
fdc0: ready for input in output
fdc0: cmd 3 failed at out byte 1 of 3
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: can't drain, serial port might not exist, disabling
sio1: can't drain, serial port might not exist, disabling
ppc0: parallel port not found.
Mounting root from ufs:/dev/ad0s3a
cd0 at ata1 bus 0 target 0 lun 0
cd0: <HL-DT-ST DVD-RW GWA-4082N CW02> Removable CD-ROM SCSI-0 device
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present
da0 at umass-sim0 bus 0 target 0 lun 0
da0: <ST96812A S > Fixed Direct Access SCSI-2 device
da0: 1.000MB/s transfers
da0: 57231MB (117210240 512 byte sectors: 255H 63S/T 7296C)
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._STA] (Node 0xc1988374), AE_NO_HARDWARE_RESPONSE
ACPI Error (uteval-0309): Method execution failed [\\_SB_.PCI0.LPC0.EC0_.BAT0._STA] (Node 0xc1988374), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_SB_.PCI0.LPC0.EC0_.ADP1._PSR] (Node 0xc1988464), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS2._TMP] (Node 0xc19836e4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS2._TMP] (Node 0xc19836e4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS2._TMP] (Node 0xc19836e4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS2._TMP] (Node 0xc19836e4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS2._TMP] (Node 0xc19836e4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
Warning: BIOS played with the 8254, resetting it
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20061109]
ACPI Exception (dswexec-0571): AE_NO_HARDWARE_RESPONSE, While resolving operands for [OpcodeName unavailable] [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_TZ_.TZS0._TMP] (Node 0xc19835a4), AE_NO_HARDWARE_RESPONSE
--
Alexander Polakov | http://rootshell.be/~polachok/


Files

dmesg.config (7.69 KB) dmesg.config polachok, 07/31/2008 10:50 PM

History

#1

Updated by qhwt+dfly about 12 years ago

:
> ukbd0: <vendor 0x04d9 USB Keyboard, class 0/0, rev 1.10/3.10, addr 2> on uhub0
> kbd1 at ukbd0

If you boot with ACPI disabled and it still doesn't work, maybe your
keyboard is only connected via USB; try below as root and see if it works.

# kbdcontrol -k /dev/kbd1 < /dev/console

Cheers.

#2

Updated by mneumann about 12 years ago

I think this is related to one of my changes to the usb code. Try
setting the following loader tunable from the boot loader:

set hw.usb.hack_defer_exploration=0

Regards,

Michael

#3

Updated by polachok almost 12 years ago

I decided to give a try to 2.0.0. The keyboard works okay with disabled acpi,
but doesn't with enabled. So, I did two things:

1) fixed dsdt to get rid of nasty errors (as in previous dmesg)
2) read man atkbd. flags atkbd0 0 helps.

thank you for your work.

Also available in: Atom PDF