Bug #1981

USB Keyboard Strangeness

Added by c.turner about 10 years ago. Updated almost 10 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:


Hello -

After finally getting around to updating one of my machines to 2.8,
I was unable to use the keyboard (USB) -

the usb key is on the front panel, the rest is on the back -
I didn't play around with which port is what (but of course
would be glad to do so)

This did not happen on the usb key boot media,
nor when booting from hdd with the usb key in my USB port -

I've tried:

- 2.8 SMP - hdd & usb key
- 2.8 UP - hdd & usb key
- HEAD SMP - hdd only
- HEAD SMP (no acpi) - hdd only

all with the same results.

Related dmesg / usbdevs from hdd acpi smp boots attached -

relavent diff seems to be that the usb key is hooked
into the 'ehci' hub - not sure how this relates
to the multiple ehci/ohci controller stuff in ehci(4) -
and it seems maybe the timing / interrupts get matched
differently depending on the presence of the key -

there's some bit about 'waiting for bios to release control'
of ehci - I'm thinking maybe if I interject a sleep into
this phase of the boot it might help -

happy to hack up my tree if anyone has ideas-
I know this does sound similar to other usb related
strangeness of late.. hmm.


- Chris


dmesg-2.8-SMP.kbd (17.7 KB) dmesg-2.8-SMP.kbd c.turner, 02/03/2011 09:25 PM
dmesg-2.8-SMP.nokbd (17.1 KB) dmesg-2.8-SMP.nokbd c.turner, 02/03/2011 09:25 PM
dmesg-2.8-SMP.nokbd2 (44.3 KB) dmesg-2.8-SMP.nokbd2 c.turner, 02/03/2011 09:25 PM
dmesg-2.9-SMP.kbd (17.4 KB) dmesg-2.9-SMP.kbd c.turner, 02/03/2011 09:25 PM
dmesg-2.9-SMP.nokbd (16.9 KB) dmesg-2.9-SMP.nokbd c.turner, 02/03/2011 09:25 PM
usbdevs-dv-2.8-SMP.kbd (982 Bytes) usbdevs-dv-2.8-SMP.kbd c.turner, 02/03/2011 09:25 PM
usbdevs-dv-2.8-SMP.nokbd (885 Bytes) usbdevs-dv-2.8-SMP.nokbd c.turner, 02/03/2011 09:25 PM
usbdevs-dv-2.9-SMP.kbd (982 Bytes) usbdevs-dv-2.9-SMP.kbd c.turner, 02/03/2011 09:25 PM
usbdevs-dv-2.9-SMP.nokbd (885 Bytes) usbdevs-dv-2.9-SMP.nokbd c.turner, 02/03/2011 09:25 PM



Updated by c.turner about 10 years ago

No idea what fixed it -
but when I accidentally blew away my / filesystem,
and recreated, it went away.

Perhaps some pre-devfs cruft was confusing things
(the / had been in place since ~1.8 or 1.10 days)


Updated by tuxillo almost 10 years ago

Can we close this one?


Updated by ahuete.devel almost 10 years ago

Sorry for the noise

2011/4/15 Antonio Huete Jimenez (via DragonFly issue tracker)
> Antonio Huete Jimenez <> added the comment:
> Can we close this one?
> _____________________________________________________
> DragonFly issue tracker <>
> <>
> _____________________________________________________

Also available in: Atom PDF