Project

General

Profile

Bug #203

rxvt problem after upgrade

Added by Johannes.Hofmann over 14 years ago. Updated about 14 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

After upgrading to HEAD rxvt hangs without showing a prompt. xterm
however works fine. Also scrolling large articles in tin feels slower
than before. I suspect this has to do with the recent
O_NONBLOCK changes.

Johannes

History

#1

Updated by dillon over 14 years ago

:After upgrading to HEAD rxvt hangs without showing a prompt. xterm
:however works fine. Also scrolling large articles in tin feels slower
:than before. I suspect this has to do with the recent
:O_NONBLOCK changes.
:
: Johannes

Yup, I can repeat that here. Ugh. ok, it's due to a change I made
to F_SETFL. It is unconditionally doing an ioctl(... FIOASYNC). I'll
get it fixed.

I dunno re: tin.

-Matt
Matthew Dillon
<>

#2

Updated by Johannes.Hofmann over 14 years ago

Matthew Dillon <> wrote:
>
> :After upgrading to HEAD rxvt hangs without showing a prompt. xterm
> :however works fine. Also scrolling large articles in tin feels slower
> :than before. I suspect this has to do with the recent
> :O_NONBLOCK changes.
> :
> : Johannes
>
> Yup, I can repeat that here. Ugh. ok, it's due to a change I made
> to F_SETFL. It is unconditionally doing an ioctl(... FIOASYNC). I'll
> get it fixed.

works as before now, thanks!

Johannes

>
> I dunno re: tin.
>
> -Matt
> Matthew Dillon
> <>

Also available in: Atom PDF