Project

General

Profile

Submit #2208

[PATCH] Enhancement the support for clang in compilers.conf

Added by juanfra684 over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

- It should not select the standards.

- Commented the lines related to clang++. It breaks buildworld.
- VERSION changed to 4.4.7 for avoid software compiling with g++ 4.1.
Authors: Sascha Wildner <>
Juan Francisco Cantero Hurtado <>
---
etc/defaults/compilers.conf | 18 ++++++++++------
1 files changed, 12 insertions(+), 6 deletions(-)

diff --git a/etc/defaults/compilers.conf b/etc/defaults/compilers.conf
index 9952679..3e7526c 100644
--- a/etc/defaults/compilers.conf
+++ b/etc/defaults/compilers.conf
@ -1,16 +1,22 @ # clang from SVN trunk #
clangsvn_CC=/usr/local/bin/clang
-clangsvn_CXX=/usr/local/bin/clang++
-clangsvn_CFLAGS="-fno-color-diagnostics -Qunused-arguments -std=gnu89"
-clangsvn_CXXFLAGS="-fno-color-diagnostics -Qunused-arguments -std=gnu++98"
-clangsvn_VERSION=4.1.2
clangsvn_CFLAGS="-fno-color-diagnostics -Qunused-arguments"
# Uncomment this lines for compile C++ code with clang.
# Disabled by default because clang+ breaks buildworld.
#clangsvn_CXX=/usr/local/bin/clang+
+#clangsvn_CXXFLAGS="-fno-color-diagnostics -Qunused-arguments"
+clangsvn_VERSION=4.4.7

  1. clang from pkgsrc #
    clang_CC=/usr/pkg/bin/clang
    -clang_CFLAGS="-fno-color-diagnostics -Qunused-arguments -std=gnu89"
    -clang_VERSION=4.1.2
    clang_CFLAGS="-fno-color-diagnostics -Qunused-arguments"
    # Uncomment this lines for compile C++ code with clang.
    # Disabled by default because clang+ breaks buildworld.
    #clang_CXX=/usr/pkg/bin/clang+
    +#clang_CXXFLAGS="-fno-color-diagnostics -Qunused-arguments"
    +clang_VERSION=4.4.7
  1. gnat-aux (i.e. gcc 4.6) from pkgsrc #
    --
    Juan Francisco Cantero Hurtado http://juanfra.info

History

#1

Updated by juanfra684 over 9 years ago

  • Status changed from New to Closed

Duplicate of #2207. Sorry.

Also available in: Atom PDF