Project

General

Profile

Actions

Bug #2661

closed

PUTTy error when trying to ssh in to a i386 box

Added by tuxillo over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Userland
Target version:
Start date:
04/09/2014
Due date:
% Done:

50%

Estimated time:

Description

Hi,

When trying to ssh in to a i386 using PUTTy on Windows I get:

"Incorrect MAC received on packet"

The culprit seems to be library ordering introduced in 35617968ec499b8b149c69bdcacfb952b81264bc although I don't know exactly what might be the cause.

Cheers,
Antonio Huete

Actions #1

Updated by ftigeot over 7 years ago

This change in secure/usr.sbin/sshd/Makefile seems to be the culprit:

-LDADD+= -lopie
-DPADD+= ${LIBOPIE}
LDADD= -lopie -lmd
DPADD= ${LIBOPIE} ${LIBMD}

Now, libopie depends on libmd. Could you try switching the order of libopie and libmd and see if it fixes this issue ?

Actions #2

Updated by zcrownover over 7 years ago

Is this isolated to i386 and PUTTy?
On Apr 9, 2014 2:28 AM, <> wrote:

Issue #2661 has been updated by ftigeot.

This change in secure/usr.sbin/sshd/Makefile seems to be the culprit:

-LDADD+= -lopie
-DPADD+= ${LIBOPIE}
LDADD= -lopie -lmd
DPADD= ${LIBOPIE} ${LIBMD}

Now, libopie depends on libmd. Could you try switching the order of
libopie and libmd and see if it fixes this issue ?

----------------------------------------
Bug #2661: PUTTy error when trying to ssh in to a i386 box
http://bugs.dragonflybsd.org/issues/2661#change-11914

  • Author: tuxillo
  • Status: New
  • Priority: Normal
  • Assignee:
  • Category: Userland
  • Target version: 3.8.0
    ----------------------------------------
    Hi,

When trying to ssh in to a i386 using PUTTy on Windows I get:

"Incorrect MAC received on packet"

The culprit seems to be library ordering introduced in
35617968ec499b8b149c69bdcacfb952b81264bc although I don't know exactly what
might be the cause.

Cheers,
Antonio Huete

--
You have received this notification because you have either subscribed to
it, or are involved in it.
To change your notification preferences, please click here:
http://bugs.dragonflybsd.org/my/account

Actions #3

Updated by tuxillo over 7 years ago

  • Status changed from New to In Progress

Hi,

Yes, from Putty to a i386 VM w/ latest.
ssh from another dfly VM works fine.

Cheers,
Antonio Huete

Actions #4

Updated by ftigeot over 7 years ago

  • % Done changed from 0 to 50

I have pushed a possible fix in 3a09db98e4bfcad6b6a4c35c45c3fb341c1b9b8d .
Can you verify it really fixed this issue ?

Actions #5

Updated by tuxillo over 7 years ago

  • Status changed from In Progress to Closed
  • Assignee set to ftigeot

It works, thanks!

Actions

Also available in: Atom PDF