Project

General

Profile

Actions

Bug #28

closed

negative number from FTP

Added by justin almost 16 years ago. Updated almost 15 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

I'm backing up one of my machines (DragonFly 1.2) to another (DragonFly
1.4) before upgrading. I used FTP from the 1.4 machine to the 1.2 machine
to bring over a 3.3G tarball, and at the end of the download, it printed
this:

226 Transfer complete.
-960809325 bytes received in 30:36 (1.73 MB/s)

It appears the ftp program appears to not be using a big enough variable
to track size. I don't know if this is inherited from FreeBSD's ftp, as I
don't have a FreeBSD system with which to test.

Actions #1

Updated by dillon almost 16 years ago

:
:I'm backing up one of my machines (DragonFly 1.2) to another (DragonFly
:1.4) before upgrading. I used FTP from the 1.4 machine to the 1.2 machine
:to bring over a 3.3G tarball, and at the end of the download, it printed
:this:
:
:226 Transfer complete.
:-960809325 bytes received in 30:36 (1.73 MB/s)
:
:It appears the ftp program appears to not be using a big enough variable
:to track size. I don't know if this is inherited from FreeBSD's ftp, as I
:don't have a FreeBSD system with which to test.
:

Looks like.   Probably easy to fix, could someone take a quick look
at the code and submit a patch ?
-Matt
Matthew Dillon
<>
Actions #2

Updated by drhodus almost 16 years ago

On 12/28/05, Justin C. Sherrill <> wrote:

I'm backing up one of my machines (DragonFly 1.2) to another (DragonFly
1.4) before upgrading. I used FTP from the 1.4 machine to the 1.2 machine
to bring over a 3.3G tarball, and at the end of the download, it printed
this:

226 Transfer complete.
-960809325 bytes received in 30:36 (1.73 MB/s)

It appears the ftp program appears to not be using a big enough variable
to track size. I don't know if this is inherited from FreeBSD's ftp, as I
don't have a FreeBSD system with which to test.

I think DFly fetch has the same problem.

-DR

Actions #3

Updated by pavalos almost 15 years ago

I haven't been able to reproduce this on HEAD with ftp or fetch. Can you try
to duplicate this again?

Actions #4

Updated by justin almost 15 years ago

Can't duplicate this on a 1.6 system - this may have been resolved by a
subsequent system update.

Actions

Also available in: Atom PDF