Project

General

Profile

Submit #2904

Update drm/uapi_drm to Linux 4.6

Added by davshao over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/27/2016
Due date:
% Done:

0%

Estimated time:

Description

Attached is a patch to update drm/uapi_drm to Linux 4.6. There should be no functional changes. The possible change in behavior in i915_drm.h, redefining the mask for invalid flags since new flags are added, is #ifdef-ed out.

The patch has been tested on a Intel integrated graphics gen7 Ivybridge machine and an AMD processor machine with a Sapphire Radeon HD6450.

The timeliness of this patch is because Matthew Macy of Nextbsd.org seems quite advanced in his own port of Linux 4.6 drm to FreeBSD, with work at

https://github.com/iotamudelta/freebsd-base-graphics

With all the great work that has been done for DragonFly, there is no reason an independent effort should not make similar progress. I apologize if this is a duplicate of no doubt better work by those who have already contributed so much to DragonFly.


Files

History

#1

Updated by ftigeot over 4 years ago

Thanks for the patch.

I'm about to push a drm/i915 update to Linux 4.3; I'll try to integrate your changes after this point.

#2

Updated by ftigeot over 4 years ago

  • Status changed from New to Closed

Commit pushed to master with a slight modification, thanks!

That modification submitted to the dri-devel list in order to further reduce differences between the Linux and DragonFly code bases:
https://lists.freedesktop.org/archives/dri-devel/2016-May/107525.html

Also available in: Atom PDF