Project

General

Profile

Actions

Bug #296

closed

PF and others

Added by elekktretterr over 15 years ago. Updated almost 15 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Hi,
Ive got this error:

Aug 17 01:06:08 porncatalog kernel: conflict with vnode 0xd6654700
Aug 17 01:06:08 porncatalog kernel: Warning: inode free race avoided 1 times

Is this a bug?

Also, my server just paniced(after about 25 days up) and Im afraid its
caused by the PF bug again, because my other box that doesnt have PF
enabled which doesnt panic.

I think this is highly critical. Any ETA on when this will be fixed?

Petr

Actions #1

Updated by geekgod over 15 years ago

Petr Janda wrote:

Hi,
Ive got this error:

Aug 17 01:06:08 porncatalog kernel: conflict with vnode 0xd6654700
Aug 17 01:06:08 porncatalog kernel: Warning: inode free race avoided 1
times

Is this a bug?

Also, my server just paniced(after about 25 days up) and Im afraid its
caused by the PF bug again, because my other box that doesnt have PF
enabled which doesnt panic.

Do you have any means of obtaining a backtrace when this occurs? It
would help the PF developers find the bug a little easier I suspect.

Scott

Actions #2

Updated by elekktretterr over 15 years ago

Well I think I will have to wait till the next month... I think there

were a bunch of backtraces already in bugs@. Unless theres some way to
recover the backtrace because the machine was just restarted.

Petr

Scott Ullrich wrote:

Petr Janda wrote:

Hi,
Ive got this error:

Aug 17 01:06:08 porncatalog kernel: conflict with vnode 0xd6654700
Aug 17 01:06:08 porncatalog kernel: Warning: inode free race avoided
1 times

Is this a bug?

Also, my server just paniced(after about 25 days up) and Im afraid
its caused by the PF bug again, because my other box that doesnt have
PF enabled which doesnt panic.

Do you have any means of obtaining a backtrace when this occurs? It
would help the PF developers find the bug a little easier I suspect.

Scott

Actions #3

Updated by corecode about 15 years ago

duplicate

Actions #4

Updated by dillon almost 15 years ago

:Hi,
:Ive got this error:
:
:Aug 17 01:06:08 porncatalog kernel: conflict with vnode 0xd6654700
:Aug 17 01:06:08 porncatalog kernel: Warning: inode free race avoided 1 times
:
:Is this a bug?

No, it can be ignored.

:Also, my server just paniced(after about 25 days up) and Im afraid its
:caused by the PF bug again, because my other box that doesnt have PF
:enabled which doesnt panic.
:
:I think this is highly critical. Any ETA on when this will be fixed?
:
:Petr

There are clearly some significant issues with PF that we haven't been
able to track down yet. I don't have an ETA.
-Matt
Matthew Dillon
<>
Actions #5

Updated by dillon almost 15 years ago

Oops. I'm sorry. That was an old message.... but I tihnk you are
still having PF problems 4 months later, right Petr ?

-Matt
Actions #6

Updated by justin almost 15 years ago

We've got a number of PF issues sitting in the bug tracker.

http://bugs.dragonflybsd.org/issue225
http://bugs.dragonflybsd.org/issue296
http://bugs.dragonflybsd.org/issue360
http://bugs.dragonflybsd.org/issue355
http://bugs.dragonflybsd.org/issue226

That last one is from corecode and is "upgrade to 3.9.". I assume the pf
version shadows OpenBSD's version, which means 4.0 is what we would
upgrade to.

If someone wanted to stake out a project, getting pf synchronized in
DragonFly would be worthwhile; it affects most everyone.

Also, ipfw1 appears to be removable with ipfw2 as a drop-in replacement;
there were patches some time back on this:

http://bugs.dragonflybsd.org/issue219

Actions #7

Updated by elekktretterr almost 15 years ago

Correct. I just have PF turned off for the time being. uptime 70+ days
at the moment.

Petr

Actions #8

Updated by corecode almost 15 years ago

note from my side: my firewall runs 70+ days with pf now. maybe just coincidence. can't tell for sure if it was fixed. before i had a reboot about every 30 days.

cheers
simon

Actions #9

Updated by elekktretterr almost 15 years ago

Are you running -HEAD? My server is running 1.6.1-RELEASE. I didnt see
any PF related bug-fixes in 1.6 and I havent cvsuped any anyway. I used
to have to reboot every 20-30 days before i turned it off.

Petr

Actions #10

Updated by corecode almost 15 years ago

no, i'm running 1.4.4-RELEASE. unfortunately i cvs up'ed my sources, so I don't know which sources I exactly use.

cheers
simon

Actions #11

Updated by elekktretterr almost 15 years ago

Do we have a summary of all bug fixes done to 1.4 in the past 6 months
or something?

Actions #12

Updated by elekktretterr almost 15 years ago

Doh! I guess i'll cvsup my server and turn PF on again.

Petr

Actions #13

Updated by justin almost 15 years ago

Does it mean this issue can be marked resolved?

http://bugs.dragonflybsd.org/issue225

Actions #14

Updated by corecode almost 15 years ago

I can't say for sure, but we can close it and re-open it when somebody reports problems again.

cheers
simon

Actions

Also available in: Atom PDF