Project

General

Profile

Actions

Bug #3183

closed

Go builder: failures connecting to locally created webservice during build tests

Added by t_dfbsd almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/01/2019
Due date:
% Done:

0%

Estimated time:

Description

The Dragonfly builder for Go reports frequent, but random failures in the crypto/tls test. The root cause seems to be an inability to connect to the local webservice created during the test. This feels kind of race-y to me and I don't see any of the other builders experiencing the problem. I don't know enough to say whether it's a Go issue or a Dragonfly issue. An example of this is:

https://build.golang.org/log/955337d30c03d9fcda402623cc29df5e24db0f84

Actions #1

Updated by t_dfbsd almost 3 years ago

  • Target version set to 13
Actions #2

Updated by sepherosa almost 3 years ago

Can you grab a tcpdump on the 127.0.0.1 during the test? I assume the
unrelated traffic on 127.0.0.1 would be low.

On Tue, Apr 2, 2019 at 1:58 AM <> wrote:

Issue #3183 has been reported by t_dfbsd.

----------------------------------------
Bug #3183: Go builder: failures connecting to locally created webservice during build tests
http://bugs.dragonflybsd.org/issues/3183

  • Author: t_dfbsd
  • Status: New
  • Priority: Normal
  • Assignee:
  • Category:
  • Target version:
    ----------------------------------------
    The Dragonfly builder for Go reports frequent, but random failures in the crypto/tls test. The root cause seems to be an inability to connect to the local webservice created during the test. This feels kind of race-y to me and I don't see any of the other builders experiencing the problem. I don't know enough to say whether it's a Go issue or a Dragonfly issue. An example of this is:

https://build.golang.org/log/955337d30c03d9fcda402623cc29df5e24db0f84

--
You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

--
Tomorrow Will Never Die

Actions #3

Updated by t_dfbsd over 2 years ago

Thw Go team has posted an update on this bug: https://github.com/golang/go/issues/29583

Actions #4

Updated by t_dfbsd over 2 years ago

  • Status changed from New to Closed

Closing this ticket. The Go team found a bug in the crypto/tls build test. From comments:

"crypto/tls: deflake localPipe in tests

The localPipe implementation assumes that every successful net.Dial
results in exactly one successful listener.Accept. I don't believe this
is guaranteed by essentially any operating system. For this test, we're
seeing flakes on dragonfly (#29583)."

I don't understand why Dragonfly was hitting this bug so often, whereas I don't recall seeing it on OpenBSD or NetBSD. In any case, it's fixed.

Actions

Also available in: Atom PDF