Project

General

Profile

Bug #50

DFly 1.4 Intel 83875P no boot

Added by corecode over 15 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

EvilTwinkie wrote:

boot -v

agp0.pci0.pcib0.legacypci0.nexus0.root0
agp0: <Intel 83875P host to AGP bridge> [tentative] mem 0-0x1ffffff at
device 0.0 on pci0
agp0: allocating GATT for aperture of size 128M

Weird. It's sitting there in contigmalloc() allocating 32 pages for the
GATT. Why this doesn't happen, I don't know.

How much RAM do you have installed?

This is my first time messing with DFly and so far I am somewhat concerned
that this bug has not been addressed. How stable is DFly? Ready for
production?

Yes, stable, though not all corner cases might be fleshed out, of course.

cheers
simon

History

#1

Updated by eviltwinkie over 15 years ago

boot -v

agp0.pci0.pcib0.legacypci0.nexus0.root0
agp0: <Intel 83875P host to AGP bridge> [tentative] mem 0-0x1ffffff at
device 0.0 on pci0
agp0: allocating GATT for aperture of size 128M

Weird. It's sitting there in contigmalloc() allocating 32 pages for the
GATT. Why this doesn't happen, I don't know.

I was able to reproduce on another identical box. After much messing with, I
was unable to get it to load completely.

How much RAM do you have installed?

1GB

concerned

that this bug has not been addressed. How stable is DFly? Ready for
production?

Yes, stable, though not all corner cases might be fleshed out, of course.

Anyone do any benchmarks vs. FBSD 6 in re: to network performance?

I was attempting to perform this test, however as you can see, I am unable
to get it to run.

#2

Updated by dillon over 15 years ago

:EvilTwinkie wrote:
:> boot -v
:>
:> agp0.pci0.pcib0.legacypci0.nexus0.root0
:> agp0: <Intel 83875P host to AGP bridge> [tentative] mem 0-0x1ffffff at
:> device 0.0 on pci0
:> agp0: allocating GATT for aperture of size 128M
:
:Weird. It's sitting there in contigmalloc() allocating 32 pages for the
:GATT. Why this doesn't happen, I don't know.
:
:How much RAM do you have installed?
:
:> This is my first time messing with DFly and so far I am somewhat concerned
:> that this bug has not been addressed. How stable is DFly? Ready for
:> production?
:
:Yes, stable, though not all corner cases might be fleshed out, of course.
:
:cheers
: simon

My guess is that the problem is the video card's aperture size.
If the video is on the motherboard, it might be possible to fix
it by adjusting the aperture size from the BIOS.
-Matt
Matthew Dillon
&lt;&gt;
#3

Updated by user about 15 years ago

Hi guys,

I have a very similar symptom and I can't finish init.

The last thing I see on the console is

pcib1: device cbb0 requested decoded memory range 0x88000000 - 0xffffffff

I can run the Olive BSD 3.8 live CD and I was hoping to be able to play
with dragonfly.....

Randux

EvilTwinkie wrote:

Greetings,

DFly 1.4
Tyan GS12

Intel 82875P

I cannot boot off the LiveCD, or from an installation dumped on a drive on a
separate system. FreeBSD 4.x + 5.x + 6.x are all OK.

During the boot process it hits the agp0 detection and then sits there like
an idiot. CTRL+ALT+DEL work fine although no ACPI messages appear.

Last three lines appear are:

boot -v

agp0.pci0.pcib0.legacypci0.nexus0.root0
agp0: <Intel 83875P host to AGP bridge> [tentative] mem 0-0x1ffffff at
device 0.0 on pci0
agp0: allocating GATT for aperture of size 128M

What should come next is the USB stuff but instead, nothing.

Single usermode is no joy
ACPI disabled is no joy
Safemode is no joy
AGP module disable via boot prompt no joy

This is my first time messing with DFly and so far I am somewhat concerned
that this bug has not been addressed. How stable is DFly? Ready for
production?

Cheers!

#4

Updated by justin about 15 years ago

On Mon, March 20, 2006 2:47 am, wrote:

Hi guys,

I have a very similar symptom and I can't finish init.

The last thing I see on the console is

pcib1: device cbb0 requested decoded memory range 0x88000000 - 0xffffffff

Have you tried the other steps that the original poster mentioned -
booting without ACPI, etc.?

cbb0 is the CardBus device, as I recall, so I assume you are using a
laptop. It may be worthwhile to check for others running that model under
FreeBSD -

http://www.cse.ucsc.edu/~dkulp/fbsd/laptop.html
http://gerda.univie.ac.at/freebsd-laptops/

#5

Updated by user about 15 years ago

Hi Justin,

Thank you for your response.

Yes, I did try the other boot options, and it stalls in the same place
on init. My PC is not listed on those other sites, but several other
PCs from the same family are (same product line but not identical
model). And, I am able to run other OpenBSD live CDs.

If anybody has other ideas please let me know.

Thank you,
Randux

Justin C. Sherrill wrote:

On Mon, March 20, 2006 2:47 am, wrote:

Hi guys,

I have a very similar symptom and I can't finish init.

The last thing I see on the console is

pcib1: device cbb0 requested decoded memory range 0x88000000 - 0xffffffff

Have you tried the other steps that the original poster mentioned -
booting without ACPI, etc.?

cbb0 is the CardBus device, as I recall, so I assume you are using a
laptop. It may be worthwhile to check for others running that model under
FreeBSD -

http://www.cse.ucsc.edu/~dkulp/fbsd/laptop.html
http://gerda.univie.ac.at/freebsd-laptops/

#6

Updated by corecode over 12 years ago

timeout closing

Also available in: Atom PDF