Bug #558


ACPI and IRQ problems

Added by slynko over 17 years ago. Updated about 2 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:



still have the same ACPI and IRQ problems on HEAD. ichsmb, cardbus and one usb
port doesn't work properly. Here is demsg messages below

Copyright (c) 2003, 2004, 2005, 2006, 2007 The DragonFly Project.
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
DragonFly 1.9.0-DEVELOPMENT #0: Wed Feb 14 15:34:06 MSK 2007
TSC clock: 1690227876 Hz, i8254 clock: 1193179 Hz
CPU: Mobile Intel(R) Celeron(R) CPU 1.70GHz (1690.24-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0xf27 Stepping = 7

real memory = 134217728 (131072K bytes)
avail memory = 122286080 (119420K bytes)
Preloaded elf kernel "/kernel" at 0xc056b000.
Preloaded elf module "/modules/vesa.ko" at 0xc056b288.
Preloaded elf module "/modules/if_ath.ko" at 0xc056b330.
ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
link_elf: symbol ieee80211_iterate_nodes undefined
link_elf_load_file: cannot load 'ath_rate' from filesystem this early
Preloaded elf module "/modules/wlan.ko" at 0xc056b3d8.
Preloaded elf module "/modules/snd_ich.ko" at 0xc056b5d4.
Preloaded elf module "/modules/sound.ko" at 0xc056b67c.
Preloaded elf module "/modules/usb.ko" at 0xc056b724.
Preloaded elf module "/modules/ums.ko" at 0xc056b7c8.
Preloaded elf module "/modules/radeon.ko" at 0xc056b86c.
Preloaded elf module "/modules/acpi.ko" at 0xc056b914.
netsmb_dev: loaded
Pentium Pro MTRR support enabled
md0: Malloc disk
pcibios: BIOS version 2.10
Using $PIR table, 7 entries at 0xc00fdf50
ACPI: RSDP 0x0xf7400/0x0014 (v 0 PTLTD )
0x0xfefa5dc/0x0030 (v 1 SONY B0 0x20021203 PTL 0x00000000)
ACPI: FACP 0x0xfefee7d/0x0074 (v 1 SONY B0 0x20021203 PTL 0x01000000)
0x0xfefa60c/0x4871 (v 1 SONY B0 0x20021203 PTL 0x0100000D)
ACPI: FACS 0x0xfefffc0/0x0040
0x0xfefeef1/0x0028 (v 1 SONY B0 0x20021203 PTL 0x00000001)
ACPI: SSDT @ 0x0xfefef19/0x00E7 (v 1 SONY B0 0x20021203 PTL 0x00000001)
npx0: <math processor> on motherboard
npx0: INT 16 interface
Using XMM optimized bcopy/copyin/copyout
acpi0: <SONY> on motherboard
Warning: ACPI is disabling APM's device. You can't run both
can't fetch resources for \\_PR_.CPU0 - AE_TYPE
can't fetch resources for \\_TZ_.ATF0 - AE_TYPE
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
ACPI Error (evregion-0427): No handler for Region [ECR_] (0xc0c92578)
[EmbeddedControl] [20061109]
ACPI Error (exfldio-0390): Region EmbeddedControl(3) has no handler [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_PR_.CPU0._CST]
(Node 0xc0c70b40), AE_NOT_EXIST
cpu0: <ACPI CPU (2 Cx states)> on acpi0
ACPI Error (evregion-0427): No handler for Region [ECR_] (0xc0c92578)
[EmbeddedControl] [20061109]
ACPI Error (exfldio-0390): Region EmbeddedControl(3) has no handler [20061109]
ACPI Error (psparse-0638): Method parse/execution failed [\\_PR_.CPU0._CST]
(Node 0xc0c70b40), AE_NOT_EXIST
acpi_tz0: <Thermal Zone> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_ec0: <Embedded Controller: GPE 0x1c> port 0x66,0x62 on acpi0
acpi_cmbat0: <Control Method Battery> on acpi0
acpi_cmbat1: <Control Method Battery> on acpi0
acpi_acad0: <AC Adapter> on acpi0
legacypci0 on motherboard
pcib0: <Intel 82845 Host to PCI bridge> on legacypci0
pci0: <PCI bus> on pcib0
agp0: <Intel 82845 host to AGP bridge> mem 0xec000000-0xefffffff at device 0.0
on pci0
pcib1: <Intel 82845 PCI-PCI (AGP) bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
drm0: <ATI Radeon LW Mobility 7500 M7> port 0x3000-0x30ff mem
0xe8100000-0xe810ffff,0xf0000000-0xf7ffffff irq 9 at device 0.0 on pci1
info: [drm] AGP at 0xec000000 64MB
info: [drm] Initialized radeon 1.8.0 20020828 on minor 0
uhci0: <Intel 82801CA/CAM (ICH3) USB controller USB-A> port 0x1800-0x181f irq 9
at device 29.0 on pci0
usb0: <Intel 82801CA/CAM (ICH3) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: 2 ports with 2 removable, self powered
uhci1: <Intel 82801CA/CAM (ICH3) USB controller USB-B> port 0x1820-0x183f irq 9
at device 29.1 on pci0
usb1: <Intel 82801CA/CAM (ICH3) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: 2 ports with 2 removable, self powered
intr 9 at 50001 > 50000 hz, livelocked limit engaged!
ums0: Logitech USB RECEIVER, rev 1.10/25.10, addr 2, iclass 3/1
ums0: 16 buttons and Z dir.
uhci2: <Intel 82801CA/CAM (ICH3) USB controller USB-C> port 0x1840-0x185f at
device 29.2 on pci0
uhci2: Could not allocate irq
device_probe_and_attach: uhci2 attach returned 6
pcib2: <PCI to PCI bridge (vendor=8086 device=2448)> at device 30.0 on pci0
pci2: <PCI bus> on pcib2
cbb0: <RF5C476 PCI-CardBus Bridge> irq 3 at device 5.0 on pci2
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
cbb1: <RF5C476 PCI-CardBus Bridge> at device 5.1 on pci2
cardbus1: <CardBus bus> on cbb1
pccard1: <16-bit PCCard bus> on cbb1
pcib2: routed slot 5 INTB to irq 255
cbb: Unable to map IRQ...
device_probe_and_attach: cbb1 attach returned 12
pci2: <unknown card> (vendor=0x1180, dev=0x0552) at 5.2
fxp0: <Intel 82801CAM (ICH3) Pro/100 VE Ethernet> port 0x4000-0x403f mem
0xe8200000-0xe8200fff irq 9 at device 8.0 on pci2
miibus0: <MII bus> on fxp0
inphy0: <i82562ET 10/100 media interface> on miibus0
inphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp0: MAC address: 08:00:46:68:73:0a
isab0: <PCI to ISA bridge (vendor=8086 device=248c)> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH3 ATA100 controller> port
0x1860-0x186f,0x374-0x377,0x170-0x177,0x3f4-0x3f7,0x1f0-0x1f7 at device 31.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
ichsmb0: <Intel 82801CA (ICH3) SMBus controller> port 0x1880-0x189f at device
31.3 on pci0
device_probe_and_attach: ichsmb0 attach returned 6
pcm0: <Intel ICH3 (82801CA)> port 0x18c0-0x18ff,0x1c00-0x1cff irq 9 at device
31.5 on pci0
pcm0: <Yamaha YMF753 AC97 Codec>
pci0: <unknown card> (vendor=0x8086, dev=0x2486) at 31.6
orm0: <Option ROMs> at iomem 0xc0000-0xcffff,0xd8000-0xdbfff,0xdc000-0xdffff on isa0
pmtimer0 on isa0
fdc0: ready for input in output
fdc0: cmd 3 failed at out byte 1 of 3
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1: can't drain, serial port might not exist, disabling
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/15 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
IP packet filtering initialized, divert enabled, rule-based forwarding enabled,
default to deny, logging disabled
ata1-slave: ATAPI identify retries exceeded
acpi_cpu: throttling enabled, 8 steps (100% to 12.5%), currently 100.0%
cbb0: CardBus card activation failed
ad0: 76319MB <HTS548080M9AT00> [155061/16/63] at ata0-master UDMA100
acd0: CD-RW <UJDA740 DVD/CDRW> at ata1-master PIO4
cd0 at ata1 bus 0 target 0 lun 0
cd0: <MATSHITA UJDA740 DVD/CDRW 1.00> Removable CD-ROM SCSI-0 device
cd0: 16.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present
Mounting root from ufs:/dev/ad0s4a
intr 9 at 7376 < 20000 hz, livelock removed

All this devices works properly on FreeBSD since 5.x
I'm ready for testing patches, and may be somebody can tell me about the part of
source tree, which is responcible for this functionality


syba-pccard-1.8.0.diff (521 Bytes) syba-pccard-1.8.0.diff c.turner, 02/15/2007 02:54 AM
Actions #1

Updated by c.turner over 17 years ago

DISCLAIMER: not sure if portions of this are 100% related .. but

on my system(s), I am:

- trying to hack in support for a no-name pci-to-cbb device from
vendor 'SYBA',which appears to be a repacaged Ricoh RL4C475
differing in the vendor id, which shows up on 1.8.0 via
`pciconf -vl` as::

none2@pci0:16:0:        class=0x066300 card=0x00000000
chip=0x04750001 rev=0x63 hdr=0x02
(see attached diff fer the 'deets of my adventures in
/usr/src/sys/dev/pccard/pccbb-land ... not sure if anyone
would want a pci vendor == 0x0001 device in-tree, but if anyone
snags one of these gismos, a diff might be useful :)

- first reboot after applied diff yielded::

cbb0: &lt;RF5C475 PCI-CardBus Bridge&gt; irq 127 at device 16.0 on pci0
cardbus0: &lt;CardBus bus&gt; on cbb0
pccard0: &lt;16-bit PCCard bus&gt; on cbb0
cbb: Unable to map IRQ...
device_probe_and_attach: cbb0 attach returned 12
the 'irq 127' seemed a bit odd (much as '255' in your dmesg)
so I tried:

- rebooting again with acpi enabled (on a dot-com boomin'
PII i440BX chipset), which yielded a pre-POST bios-level irq conflict.

- rebooted yet again, entered bios and disabled local lpt / 1284 /
printer port, and:

- rebooted again w/o ACPI, resulting in many

"sched_ithd: stray interrupt 7" messages - appearing to make
ye-olde kernel enter an endless?? interrupt handling loop
see also:
although this particular kernel is UP..

- rebooted with acpi enabled.. this time, cbb seemed to attach as

cbb0: &lt;RF5C475 PCI-CardBus Bridge&gt; at device 16.0 on pci0
cardbus0: &lt;CardBus bus&gt; on cbb0
pccard0: &lt;16-bit PCCard bus&gt; on cbb0
thinking I'd made the SYBA cbb0 work, I tried to test my loaner
verizin wharless PC5740 cdma card, to no avail::
cardbus0: Resource not specified in CIS: id=10, size=1000
cardbus0: &lt;unknown card&gt; (vendor=0x0000, dev=0x0000) at 0.0
cbb0: CardBus card activation failed
cardbus0: Resource not specified in CIS: id=10, size=1000
ohci0: &lt;NEC uPD 9210 USB controller&gt; mem 0x88001000-0x88001fff irq 3
at device 0.0 on cardbus0
usb1: OHCI version 15.15, legacy support
usb1: unsupported OHCI revision
ohci0: USB init failed
device_probe_and_attach: ohci0 attach returned 5
unfortunately, as this is the only pcmcia/cardbus card I have A.T.M,
I have no idea as to whether my hacked driver is borked or if the
cdma card isn't quite working properly.. and would prefer to know
this before I try to tackle something with OHCI v15.15??..

So, I decided to:

- boot up my laptop (ferrari 1000)
- and try the card.
- recieved the same errors about the PCcard not working on insert
time, making me a tad-more confident about the SYBA cbb hack..

what is interesting is that on the F1000:

- issue #387,
is also apparent (has bge0)

- I am getting the same "sched_ithd: stray interrupt 7" errors,
but not in the endless-loop?? mentioned above, and the PII box has
never (since 1.4.x) had the stray interrupt errors until the cbb
was added

- the F1000 has an EHCI interface, related to 'stray interrupt 7' errors
I've not yet tried any usb devices on it..

- when APIC_IO is enabled as mentioned in #387, bge gets the #387
timeouts, a higher frequency of 'stray interrupts' are apparent,
and one cpu is near-totally consumed (according to top(1)).
When APIC_IO is disabled, both cores / CPU's idle as expected and
bge0 works fine, with less 'stray interrupt 7' errors..

- acpi was "better" than no-acpi on the F100, for reasons I can't
quite remember.

I understand based on the discussion of one-or-another of the issues
relating to ACPI that possibly interrupt routing might take a bit
of work to get sorted out..

but perhaps a few drivers / bioses / options are making this worse.
cbb, bge, lpt, APIC_IO, SMP, radeon? on recent dual core (laptop?)
models come to mind here..

Also, I recall in the near-to-1.8 release list threads, someone having
trouble with a IBM core-2 laptop conflagaration overheating -
perhaps the CPU usage I saw related to having APIC_IO enabled might
resolve this for that person...

having trouble finding chipset info on the F1000 at the moment, based on
this appears to be a Radeon Xpress 1150 .. which I thought was just the
Grapics chip.. but anyhow.

(mentions apics and interrupt 7s)

in any case, just a ton of disorganized and possibly worthless data
points I suppose.. and my kernel newbness doesn't help understainding
how interrupt routing works.. sigh..

n.e. way: mostly off topic and last-but-not-least:

My F1000 has what appears to be a bcw(OpenBSD4) wifi chip...

see also:

thinking of attempting the port, unless anyone else is working on it...


sorry for the disorganization of this post / relavence to initial
issue.. but as often, when the details are vague,
things are tougher to sift through.

Thanks again for DragonFly!

- Chris

Actions #2

Updated by c.turner over 17 years ago

Chris Turner wrote:

- I am getting the same "sched_ithd: stray interrupt 7" errors,


funny, that I should 'spam' the bug list about this problem
when I didn't know about the CPU_AMD64X2_INTR_SPAM option..

which if anyone is getting lots of these errors, is worth checking out..
my apologies... gotta read that LINT!

Actions #3

Updated by dillon over 17 years ago

:Chris Turner wrote:
:> - I am getting the same "sched_ithd: stray interrupt 7" errors,
:funny, that I should 'spam' the bug list about this problem
:when I didn't know about the CPU_AMD64X2_INTR_SPAM option..
:which if anyone is getting lots of these errors, is worth checking out..
:my apologies... gotta read that LINT!

That option only works with multi-core AMD cpus, and only if the BIOS
has not properly programmed the hypertransport bus's interrupt routing.
There are issues with various motherboard chipsets and cpus that cause
spurious interrupts, either due to bugs in the hardware, bad hardware
design, bugs in the BIOS, or lack of documentation. Unfortunately
there is very little we can do about most of these issues.
Matthew Dillon
Actions #4

Updated by tuxillo over 11 years ago

  • Description updated (diff)
  • Status changed from New to Feedback
  • Assignee deleted (0)


There were major changes on the areas mentioned in this ticket.
I don't think this is still relevant but if somebody could confirm it by checking with latest master (or at least with RELEASE), it would be great.

Antonio Huete

Actions #5

Updated by tuxillo about 2 years ago

  • Description updated (diff)
  • Category set to Kernel
  • Status changed from Feedback to Closed
  • Assignee set to c.turner
  • % Done changed from 0 to 100

Ancient bug and no feedback was reported even tho it was stated there have been significant changes that could potentially fix the issues.


Also available in: Atom PDF