Project

General

Profile

Actions

Bug #583

closed

Double nfs mount freezes machine

Added by thomas.nikolajsen over 15 years ago. Updated over 15 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Using recent HEAD or 1.8-release:
Executing a nfs mount command twice and accessing the mount point
will freeze machine (client).

Break to DDB works.

Eg:
#mount /NFS
#mount /NFS
#ls /NFS

-thomas

Actions #1

Updated by corecode over 15 years ago

seems we have problems with multiple mounts on one mountpoint?

Actions #2

Updated by dillon over 15 years ago

:
:Simon 'corecode' Schubert <> added the comment:
:
:seems we have problems with multiple mounts on one mountpoint?
:
:----------
:priority: -> critical
:status: unread -> chatting

Yes, we do.  I reproduced it and I am working on it now.  I
should be able to track it down today.
It looks like an infinite loop somewhere, I'm not sure
where yet. It happens with any mount but is easiest to
reproduce with NFS and MFS.
-Matt
Matthew Dillon
&lt;&gt;
Actions

Also available in: Atom PDF