Project

General

Profile

Actions

Bug #698

closed

burncd error

Added by josepht over 14 years ago. Updated about 14 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

I get the following error when I try to burn a CD with burncd:

next writeable LBA 0
writing from file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso size
417792 KB

only wrote -1 of 32768 bytes err=30

I believe this is EROFS. Here's the relevant dmesg lines:

atapci0: <Intel ICH7M SATA controller> port
0x18b0-0x18bf,0-0x3,0-0x7,0-0x3,0-0x
7 irq 18 at device 31.2 on pci0

ata1: at 0x170 irq 15 on atapci0
acd0: DVD-R <PIONEER DVD-RW DVR-K16A> at ata1-master UDMA33
cd0 at ata1 bus 0 target 0 lun 0
cd0: <PIONEER DVD-RW DVR-K16A 1.63> Removable CD-ROM SCSI-0 device
cd0: 33.000MB/s transfers
cd0: cd present [224926 x 2048 byte records]

I also see these lines in dmesg:

acd0: READ_TRACK_INFO - ILLEGAL REQUEST asc=0x24 ascq=0x00 error=0x00
acd0: READ_TRACK_INFO - ILLEGAL REQUEST asc=0x24 ascq=0x00 error=0x00
acd0: READ_TRACK_INFO - ILLEGAL REQUEST asc=0x24 ascq=0x00 error=0x00
acd0: READ_BIG - BLANK CHECK asc=0x00 ascq=0x00 error=0x00
acd0: READ_BIG - BLANK CHECK asc=0x00 ascq=0x00 error=0x00

Here's my uname output:

DragonFly hostname 1.9.0-DEVELOPMENT DragonFly
1.9.0-DEVELOPMENT #163: Sat Jun 9 09:56:45 EDT 2007
root@hostname:/home/obj/usr/src/sys/NEPTUNE i386

Note: I'm still not running a NATA kernel. I seem to remember reading
somewhere that CD-ROM drives on SATA controllers were not supported so
this may be what I'm running into.

Thanks,
Joe

Actions #1

Updated by dillon over 14 years ago

:I get the following error when I try to burn a CD with burncd:
:
:next writeable LBA 0
:writing from file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso size
:417792 KB
:
:only wrote -1 of 32768 bytes err=30
:
:I believe this is EROFS. Here's the relevant dmesg lines:

Synchronize to the latest HEAD, make sure you do a full build/install
of the kernel, world, and also do a make upgrade. Also note that
when burning a CD you have to use the raw CD device (e.g. /dev/acd0,
not /dev/acd0c).
I had a similar error in an earlier HEAD, and I did fix it.
-Matt
Matthew Dillon
&lt;&gt;
Actions #2

Updated by josepht over 14 years ago

I sync'ed to HEAD and enabled NATA in the process. Did a full
build/install kernel, world, and did a make upgrade. I am now getting
this error:

josepht@tin$ sudo burncd -v -s 10 -f /dev/acd0 data
~/tar-files/Minix-IDE-3.1.2a.iso
adding type 0x08 file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso
size 417792 KB 208896 blocks
next writeable LBA 1424
addr = 1424 size = 427819008 blocks = 208896
writing from file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso size
417792 KB
written this track 1120 KB (0%) total 1120 KB
only wrote -1 of 32768 bytes err=5

The non-zero LBA is due to me trying this command several times on the
same blank disk. I am assuming that this is not causing the problem
and don't want to waste a bunch of disks testing this out. If this
could be causing my problem let me know and I'll try a brand new blank
disk.

Here are the relevant lines from dmesg:

atapci0: <Intel ICH7M SATA300 controller> port
0x18b0-0x18bf,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 irq 18 at device
31.2 on pci0
ata0: <ATA channel 0> on atapci0
ad1: 76319MB <TOSHIBA MK8032GSX AS112M> at ata0-master SATA150
ata1: <ATA channel 1> on atapci0
acd0: DVDR <PIONEER DVD-RW DVR-K16A/1.63> at ata1-master UDMA33

(my HDD changed from ad0 to ad1 which I assume is from switching to
NATA).

There are no errors in dmesg from the failed burn attempt.

Thanks,
Joe

Actions #3

Updated by dillon over 14 years ago

Oh, one more thing... when you are doing a test burn (or a real burn),
do NOT ^C burncd, it will leave the CDRom drive in an unusable state
that will probably need a power cycle to fix.

-Matt
Actions #4

Updated by dillon over 14 years ago

:The non-zero LBA is due to me trying this command several times on the
:same blank disk. I am assuming that this is not causing the problem
:and don't want to waste a bunch of disks testing this out. If this
:could be causing my problem let me know and I'll try a brand new blank
:disk.
:
:..
:Thanks,
:Joe

Mmm.  Bad assumption.  Try a new disk, and put it in test mode so it
doesn't actually write to the CD (so you don't wind up hucking too
many of them into the trash). That's -t to burncd.
-Matt
Matthew Dillon
&lt;&gt;
Actions #5

Updated by josepht over 14 years ago

Same error with a brand new blank disk and using -t.

josepht@tin$ sudo burncd -vt -s 10 -f /dev/acd0 data
~/tar-files/Minix-IDE-3.1.2a.iso
Password:
adding type 0x08 file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso
size 417792 KB 208896 blocks
next writeable LBA 0
addr = 0 size = 427819008 blocks = 208896
writing from file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso size
417792 KB
written this track 1120 KB (0%) total 1120 KB
only wrote -1 of 32768 bytes err=5

Joe

Actions #6

Updated by dillon over 14 years ago

:Same error with a brand new blank disk and using -t.
:
:josepht@tin$ sudo burncd -vt -s 10 -f /dev/acd0 data
:~/tar-files/Minix-IDE-3.1.2a.iso
:Password:
:adding type 0x08 file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso
:size 417792 KB 208896 blocks
:next writeable LBA 0
:addr = 0 size = 427819008 blocks = 208896
:writing from file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso size
:417792 KB
:written this track 1120 KB (0%) total 1120 KB
:only wrote -1 of 32768 bytes err=5
:
:Joe

ls -la /dev/acd0, this is what it should be:
test28# ls la /dev/acd0
crw-r----
1 root operator 117, 0x10010000 Jun 8 18:08 /dev/acd0
-Matt
Matthew Dillon
&lt;&gt;
Actions #7

Updated by josepht over 14 years ago

It is:

josepht@tin$ ls al /dev/acd0
crw-r----
1 root operator 117, 0x10010000 Jun 14 14:33 /dev/acd0

Also after running burncd with -t I tried running it again and got
this:

josepht@tin$ sudo burncd -vt -s 10 -f /dev/acd0 data
~/tar-files/Minix-IDE-3.1.2a.iso
Password:
adding type 0x08 file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso
size 417792 KB 208896 blocks
next writeable LBA 712
addr = 712 size = 427819008 blocks = 208896
writing from file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso size
417792 KB
written this track 1120 KB (0%) total 1120 KB
only wrote -1 of 32768 bytes err=5

Does that LBA 712 mean that something was actually written to the CDR
with the -t flag?

Joe

Actions #8

Updated by dillon over 14 years ago

:It is:
:
:josepht@tin$ ls al /dev/acd0
:crw-r----
1 root operator 117, 0x10010000 Jun 14 14:33 /dev/acd0
:
:Also after running burncd with -t I tried running it again and got
:this:
:
:josepht@tin$ sudo burncd -vt -s 10 -f /dev/acd0 data
:~/tar-files/Minix-IDE-3.1.2a.iso
:adding type 0x08 file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso
:size 417792 KB 208896 blocks
:next writeable LBA 712
:addr = 712 size = 427819008 blocks = 208896
:writing from file /home/josepht/tar-files/Minix-IDE-3.1.2a.iso size
:417792 KB
:written this track 1120 KB (0%) total 1120 KB
:only wrote -1 of 32768 bytes err=5
:
:Does that LBA 712 mean that something was actually written to the CDR
:with the -t flag?
:
:Joe

It is saying error 5, which is EIO.  Maybe the problem is the 10x
writing speed? Try -s 4 instead of -s 10 maybe?
I don't know what's going own with the writable LBA of 712.  Maybe
that particular drive doesn't support test mode. Weird.
I can burn CDs with burncd and acd0 on my test box, so I'm fairly
sure the protocol is working properly in HEAD:
test28# burncd -v -s 4 -f /dev/acd0 data /usr/release/dfly.iso fixate
adding type 0x08 file /usr/release/dfly.iso size 278234 KB 139117 blocks
next writeable LBA 0
addr = 0 size = 284911616 blocks = 139117
writing from file /usr/release/dfly.iso size 278234 KB
written this track 65536 KB (23%) total 65536 KB
...
-Matt
Matthew Dillon
&lt;&gt;
Actions #9

Updated by josepht over 14 years ago

I tried -s {1,2,4} and all returned EIO.

When I first got this laptop before I installed DragonFly I booted it
with the original Windows XP install and a dialog box popped up that
asked if I wanted to use the drive in DVD or CD mode or some such
rubbish. I am wondering now if there is some config register in the
hardware that has to be set to switch between CD and DVD modes (I
guess for writing since reading CDs works).

After rebooting the LBA restarted at 0 and increments after each
attempt.

Joe

Actions #10

Updated by dillon over 14 years ago

:When I first got this laptop before I installed DragonFly I booted it
:with the original Windows XP install and a dialog box popped up that
:asked if I wanted to use the drive in DVD or CD mode or some such
:rubbish. I am wondering now if there is some config register in the
:hardware that has to be set to switch between CD and DVD modes (I
:guess for writing since reading CDs works).

Wait.  Did burncd EVER work on that laptop with DragonFly?  e.g.
1.8, before all the work I did this last month?
-Matt
Actions #11

Updated by josepht over 14 years ago

I never tried. So many things on this laptop didn't work that burning
CDs was pretty low on my list. I did try playing a DVD with no
success.

Joe

Actions #12

Updated by dillon over 14 years ago

:I never tried. So many things on this laptop didn't work that burning
:CDs was pretty low on my list. I did try playing a DVD with no
:success.
:
:Joe

Ok.  I don't know if the problem is due to recent changes or if it's
a long term issue.
One last thing you could try is cdrecord.  cdrecord takes some getting
used to because it uses the SCSI API and it is kinda messy. Even though
it is still talking to the same ATA device, there's a chance it might
work where burncd doesn't.
Get cdrecord from pkgsrc via sysutils/cdrtools-ossdvd
It has a test mode also.  Basically it works something like this:
cdrecord -scanbus
Figure out what scsi device the ATA CD-Drive attached as.  That's
the device you specify in the below commands.
cdrecord dev=1,0,0 -checkdrive
This will print out the drive information.  It may ring a bell with
someone.
cdrecord dev=1,0,0 speed=4 -v -dummy -sao ISOFILE
This does a burn.  I think. (in dummy mode == test mode).
-Matt
Matthew Dillon
&lt;&gt;
Actions #13

Updated by elekktretterr over 14 years ago

Hey,
I'd just like to add that burncd has never worked for me either. its been
very long since i tried last time though. Maybe i should find my cd-rws
and try again..

Actions #14

Updated by josepht over 14 years ago

cdrecord works.

Joe

Actions #15

Updated by joerg over 14 years ago

I strongly recomment to use the primary version, it should support
anything the ossdvd patch was supposed to add and it is more actively
maintained. Doesn't change any of the rest.

Joerg

Actions #16

Updated by corecode about 14 years ago

should we keep this bug around until burncd is fixed?

Actions #17

Updated by josepht about 14 years ago

I say close it. The CDROM drive seems a bit flaky anyway.

Actions #18

Updated by dillon about 14 years ago

:Simon 'corecode' Schubert <> added the comment:
:
:should we keep this bug around until burncd is fixed?
:
:----------
:priority: -> bug

No, close it.  burncd is effectively just a simplified version of
cdrecord, it isn't going to work on all CDs.
-Matt
Matthew Dillon
&lt;&gt;
Actions

Also available in: Atom PDF